Все публикации

БСП
Разработки

Программная установка параметров выбора на примере банковских счетов из ERP 2.5

ERP 2.5

&НаСервереБезКонтекста
Функция ПараметрыВыбораБанковскихСчетов(ОплатаВВалюте, Организация)

	МассивПараметров = Новый Массив;
	
	Если НЕ ОплатаВВалюте Тогда
		МассивПараметров.Добавить(Новый ПараметрВыбора("Отбор.ВалютаДенежныхСредств",
					ЗначениеНастроекПовтИсп.ВалютаРегламентированногоУчетаОрганизации(Организация)));
	Иначе
		МассивПараметров.Добавить(Новый ПараметрВыбора("Отбор.ВалютаДенежныхСредств", Новый ФиксированныйМассив(ИностранныеВалюты(Организация))));
	КонецЕсли;
	
	МассивПараметров.Добавить(Новый ПараметрВыбора("ВыборСчетовГоловнойОрганизации", Неопределено));
	МассивПараметров.Добавить(Новый ПараметрВыбора("Отбор.Закрыт", Ложь));
	
	Возврат Новый ФиксированныйМассив(МассивПараметров);
	
КонецФункции

&НаСервере
Процедура ПриЧтенииНаСервере()
	ПараметрыВыбораБанковскогоСчета = ПараметрыВыбораБанковскихСчетов(Ложь, Объект.Организация);
	Элементы.БанковскийСчет.ПараметрыВыбора            = ПараметрыВыбораБанковскогоСчета;
	Элементы.БанковскийСчетКонтрагента.ПараметрыВыбора = ПараметрыВыбораБанковскогоСчета;
КонецПроцедуры

Как отфильтровать объекты по типу в "Навигаторе по метаданным"

Когда нужно установить фильтр по типу, просто добавите слеш / и первые буквы типа. Например, для отбора по справочникам /Спр Для отбора по общим модулям /Общ (отбор можно ставить как в начале так и в конце строки) Для форм /форм и т.д.
bolsun 392 6 8 6

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз Промо

Быстрое и надежное обновление файловых и серверных баз, защита от шифровальщиков, автоматическое обновление доработанных конфигураций и расширений, а также многое другое.
bolsun
950 руб.

Прочитать таблицу значений из XML

Производит десериализацию таблицы значений из строки XML
bolsun 392 6 8 6
Функция ПрочитатьТаблицуИзXML(СтрокаXML)
    
    ЧтениеXML = Новый ЧтениеXML;
    ЧтениеXML.УстановитьСтроку(СтрокаXML);
    ТипОбъектаXDTO = ФабрикаXDTO.Тип("http://v8.1c.ru/8.1/data/core","ValueTable");
    ОбъектXDTO = ФабрикаXDTO.ПрочитатьXML(ЧтениеXML,ТипОбъектаXDTO); 
    ОбъектXDTO.Проверить();
    
    ЧтениеXML.Закрыть();
    ТЗ = СериализаторXDTO.ПрочитатьXDTO(ОбъектXDTO);
    Возврат ТЗ;
    
КонецФункции

Записать таблицу значений в XML

Производит сериализацию таблицы значений из возвращает ЗаписьXML.
bolsun 392 6 8 6
Функция ЗаписатьТаблицуВXML(ТЗ)
    
    ЗаписьXML = Новый ЗаписьXML;
    ЗаписьXML.УстановитьСтроку();
    ОбъектXDTO = СериализаторXDTO.ЗаписатьXDTO(ТЗ.Выгрузить());
    ФабрикаXDTO.ЗаписатьXML(ЗаписьXML, ОбъектXDTO);
    Возврат ЗаписьXML.Закрыть();
    
КонецФункции

Улучшаем игру Diablo 2 Resurrected с TurboConf

Несмотря на то, что потихоньку разработчики улучшают интерфейс игры, тем не менее многих удобных функций все еще нет. Например, в игре есть очень полезное умение - Battle Order. Оно увеличивает жизнь и ману персонажа на небольшой промежуток времени. Исп...
bolsun 392 6 8 6

Как зарегистрироваться в ChatGPT из России

На текущий день нейросеть не доступна в РФ. В статье несколько советов как это обойти и попробовать возможности ChatGPT. После предыдущей публикации Запрос к нейросети ChatGPT мне задавали вопрос, как обойти ограничения на работу с сервисом из РФ. Сдела...
bolsun 392 6 8 6

Записать таблицу значений в XML файл

Сериализует таблицу значений и сохраняет ее в файл xml.
bolsun 392 6 8 6
Процедура СохранитьТаблицуВФайлXML(ИмяФайла, ТЗ)
	
	Сериализатор = Новый СериализаторXDTO(ФабрикаXDTO);
	XML = Новый ЗаписьXML;
	XML.ОткрытьФайл(ИмяФайла);
	Сериализатор.ЗаписатьXML(XML, ТЗ);
	XML.Закрыть();

КонецПроцедуры

Исправляем неработающие горячие клавиши в Конфигураторе 1С

На некоторых компьютерах может не работать комбинация Ctrl+Alt+M - для поиска по метаданным, Alt+F2 - установка закладки и другие хоткеи. Помимо 1С, это может влиять на правильную работу и других программ, которые используют взаимодействие с конфигурат...
bolsun 392 6 8 6

Быстрое добавление объекта в кэш

TurboConf получает список объектов конфигурации из кэша, который формирует из "Отчета по конфигурации". Этот кэш используется для быстрой навигации, в подсказках и в других функциях. Как быстро добавить новый объект, без обновления кэша целиком? Обычно ...
bolsun 392 6 8 6

Ввод специальных символов без переключения раскладки

Это одна из самых простых функций TurboConf, но тем не менее пользователи иногда спрашивают как это сделать. Для ввода, просто нажмите Alt + нужный символ на любой раскладке.
bolsun 392 6 8 6

СообщитьОтложенныеСообщения(Знач СообщенияПользователю)

Поддерживаемые контексты: клиент, сервер // Выводит сообщения пользователю из заранее подготовленного массива объектов СообщениеПользователю. // Массив предварительно может быть получен методом ПолучитьСообщенияПользователю. // Рекомендуется применять, ...
John Doe 16 1

Выбор каталога (папки) файловой системы

Шаблон кода для выбора каталога. Вешать на событие НачалоВыбора к полю ввода. // Процедура - Имя каталога начало выбора // Обработка события НачалоВыбора поля ввода для выбора каталога // В процедуре определяется имя реквизита по Элементу куда нужно зап...
СергейТ 57 2 6

Таблица значений с колонкой любого имени (без ограничений используемых символов)

Возвращает новую таблицу значений с добавлением новой колонки в обход ограничений доступных символов в имени. Использовать не рекомендуется. Просто забавы ради
SeiOkami 388 5 7 7

Минимум усилий и максимум пользы: дополнительный заработок для разработчика 1С

Бесплатно

Запрос к нейросети ChatGPT

Пример Http запроса и получения ответа от нейросети ChatGPT (OpenAI)
bolsun 392 6 8 6
//Описание API https://beta.openai.com/docs/api-reference/

Процедура ЗапросКChatGPT(Текст)
	
	Соединение = Новый HTTPСоединение("api.openai.com",,,,,,Новый ЗащищенноеСоединениеOpenSSL());
		
	Заголовки=Новый Соответствие();
	Заголовки.Вставить("Content-Type", "application/json");
	Заголовки.Вставить("Authorization", "Bearer <Ваш API-Key>");
	
	Запрос = Новый HTTPЗапрос();
	Запрос.АдресРесурса = "v1/completions";
	Запрос.Заголовки = Заголовки;
		
    ТелоЗапроса = 
    "
	|{
  |""model"": ""text-davinci-003"",
  |""prompt"": """ + Текст+ """,
  |""max_tokens"": 100,
  |""temperature"": 0,
  |""top_p"": 1,
  |""n"": 1,
  |""stream"": false,
  |""logprobs"": null,
  |""stop"": "".""
  |}";
	
	Запрос.УстановитьТелоИзСтроки(ТелоЗапроса);
	
	Ответ=Соединение.ОтправитьДляОбработки(Запрос);
	
	КодСостояния=Ответ.КодСостояния;
	СтрокаОтвета=Ответ.ПолучитьТелоКакСтроку();
	
	Если КодСостояния=200 Тогда
		//Ответ в виде Json
		Сообщить(СтрокаОтвета);
	Иначе
		//Ошибка при выполнении запроса
	КонецЕсли;		
    
КонецПроцедуры

Обмен с помощью Web - Сервисов. Новый (С примерами)

Продолжим цикл статей про обмены с помощью встроенных механизмов 1С -Web-Сервисы. Рассмотрим простой пример самописного обмена с мобильным приложением. Для начала создаем Web-Сервис (С наименованием "ObmenMobil"). -URl пространство имен - вводим ip адре...
Артур 105 2 2 3

Проверка справочника или документа на модифицированность

Навеяно публикацией В отличии от оригинальной публикации значения до редактирования читаются одним запросом, как рекомендуют стандарты 1С. Функция ОбъектМодифицирован(Объект) МетаданныеОбъекта = Объект.Метаданные(); Если Метаданные.Справочники.Содержит(М...
Little Friend 19 1 1

Копирование файлов

Копирование файлов из одного каталога в другой Навеяно публикацией Изначально не понравился метод определения типа файла - файл это или каталог. Автор считает, что если файл не имеет расширения, то это каталог, что в корне не правильно. В итоге привожу ...
Little Friend 19 1 1

Функция сравнения значений (рекурсивно)

Позволяет сравнивать значение с эталонным как строго (точное совпадение полей, количества и последовательности элементов массивов), так и не строго (все элементы эталона есть в значении). Описание параметров: Значение - сравниваемое значение. Может быть...
ChOP 217 2 9 6

История пользователя не обновляется, при программном добавлении события

Имеем открытие файла из любого места, откуда его можно открыть и в общем модуле, где это все пересекается между собой есть строка ИсторияРаботыПользователя.Добавить(ПолучитьНавигационнуюСсылку(СсылкаНаФайл)); Однако в самой истории, в отладчике, через Исто...