Перейти к началу/концу метода

1 22 апреля 2019 10:01

TurboConf SDK Скрипты Помощь


Скрипт выполняет переход к началу/концу текущей процедуры или функции

Перейти к началу метода Ctrl+Alt+[

Перейти к концу метода Ctrl+Alt+]

Image https://turboconf.ru/Content/Files/31C694EEA2260A37464FB9F25FA7B436FB000A06/GoToMethodStartEnd.png

Скрипт войдет в следующую поставку TurboConf, а пока можно скачать его здесь.

Поместите скрипт в папку ./scripts и нажмите Ctrl+Shift+R в конфигураторе для перезагрузки скриптов

//@script_name GoToMethodStartEnd
//@script_display_name Перейти к началу/концу текущего метода
//@script_description Скрипт выполняет переход к началу/концу текущей процедуры/функции
//@script_author m.bolsun
//@script_developer_url https://turboconf.ru
//@script_hotkey Control+Alt+OemOpenBrackets ПерейтиКНачалуМетода
//@script_hotkey Control+Alt+OemCloseBrackets ПерейтиККонцуМетода
//@retain_clipboard 0
//@enterprise_mode 0
//@hide_actions 0

Процедура ПерейтиКНачалуМетода()

	Перейти(Истина);
	
КонецПроцедуры

Процедура ПерейтиККонцуМетода()
	
	Перейти(Ложь);
	
КонецПроцедуры

Процедура Перейти(КНачалуМетода)
	
	ТК = Новый ТурбоКонф; 
	
	ТК.Key(Keys.Home);
	
	ТК.ControlAltKey(Keys.P);
	
	Окно = ТК.ЖдатьОкно("Процедуры и функции", 2000, Истина, Ложь);
	
	ТК.Key(Keys.Enter);

	Если КНачалуМетода Тогда
	
		Возврат;
		
	КонецЕсли;

	ТК.ЖдатьЗакрытияОкна(Окно, "Процедуры и функции", 1000);

	ТК.ControlKey(Keys.OemCloseBrackets);

КонецПроцедуры

Товары

Перейти к началу/концу метода

12
2

Автоматическая установка с TurboConf

1. Откройте маркетплейс из главного меню TurboConf или из меню в панели уведомлений.

Откройте маркетплейс

2. Найдите нужную разработку.

Найдите нужную разработку

3. Нажмите кнопку Установить.

Нажмите кнопку Установить

TurboConf все установит автоматически!

Комментарии

bolsun
#1, 16 февраля 2021 15:45

bolsun переместил тему в раздел Скрипты пользователей


AlekseiAdamov
#2, ред. 12 января 2024 10:00

В самом конце желательно добавить переход в начало строки, потому что иначе экран не сдвигается на конец метода:

ТК.Key(Keys.Home);

То же самое можно сделать перед возвратом, чтобы снять выделение с первой строки метода.


Модератору