Преобразовать строку в имя

21 января 2020 23:20
Phoenix

TurboConf Скрипты

Скачать

Преобразовать строку в имя по правилу CamelCase: Мое название переменной БО -> МоеНазваниеПеременнойБО



//@script_name ConvertToName
//@script_display_name Преобразовать строку в имя
//@script_description Преобразовать строку в имя по правилу CamelCase:  Мое название переменной БО -> МоеНазваниеПеременнойБО
//@script_author sushakov
//@script_developer_url PhoenixUSA@yandex.ru
//@script_hotkey Alt+Shift+N ПреобразоватьСтрокуВИмя
//@retain_clipboard 1
//@hide_actions 0

#Область ПрограммныйИнтерфейс

Процедура ПреобразоватьСтрокуВИмя() Экспорт
	
	ТурбоКонф = Новый ТурбоКонф;
	
	ПозицияКурсора  = 0;
	ВыделенныйТекст = "";
	
	ТурбоКонф.ПолучитьТекстМодуля(ВыделенныйТекст, ПозицияКурсора);

	ДопустимыеСимволы = "йцукенгшщзхъфывапролджэячсмитьбю"
		+ "qwertyuiopasdfghjklzxcvbnm"
		+ " _1234567890";
	
	ДопустимыйТекст = "";
	ДлинаСтроки = СтрДлина(ВыделенныйТекст);
	Для А = 1 По ДлинаСтроки Цикл
		
		СимволИзСтроки = Сред(ВыделенныйТекст, А, 1);
		Если СтрНайти(ДопустимыеСимволы, НРег(СимволИзСтроки)) > 0 Тогда
			ДопустимыйТекст = ДопустимыйТекст + СимволИзСтроки;
		КонецЕсли;
		
	КонецЦикла;
	
	МассивСлов = СтрРазделить(ДопустимыйТекст, " ", Ложь);
	
	НовыйТекст = "";
	Для каждого Слово Из МассивСлов Цикл
		НовыйТекст = НовыйТекст + (ВРег(Лев(Слово, 1)) + Сред(Слово, 2));
	КонецЦикла;

	// Без этой строки дублирует текст, если он до знака равно
	ТурбоКонф.Key(Keys.Delete);
	
	ТурбоКонф.ВставитьТекст(НовыйТекст);
	
КонецПроцедуры

#КонецОбласти

Товары

Преобразовать строку в имя

Скачать 3

См. также

cmdline

RegEx1CAddin - внешняя компонента для выполнения регулярных выражений RegEx в 1С

Глобальные расширения и скрипты

Комментарии

Phoenix
#1, 22 января 2020 20:09

<gif>https://turboconf.ru/Content/Files/AA72F36E109C374BCDB44FA18593410B24CE1F4D/TurboConf-ConvertToName.png</gif>


Phoenix
#2, ред. 16 февраля 2021 16:07

https://turboconf.ru/Content/Files/AA72F36E109C374BCDB44FA18593410B24CE1F4D/ConvertToName.os


bolsun
#3, 16 февраля 2021 15:45

bolsun переместил тему в раздел Скрипты пользователей


Модератору