ЗаполнитьМассивУникальнымиЗначениями

bolsun 299 5 3 7

Заполняет массив-приемник уникальными значениями из массива-источника.

// Заполняет массив-приемник уникальными значениями из массива-источника.
// Если элемент в массиве-приемнике уже существует, то добавления нового элемента не происходит.
//
// Параметры:
//  МассивПриемник – Массив – массив, который заполняется уникальными значениями
//  МассивИсточник – Массив – массив, из которого подбираются элементы в массив-приемник.
// 
Процедура ЗаполнитьМассивУникальнымиЗначениями(МассивПриемник, МассивИсточник) Экспорт
	
	Для Каждого Элемент Из МассивИсточник Цикл
		
		Если МассивПриемник.Найти(Элемент) = Неопределено Тогда
			
			МассивПриемник.Добавить(Элемент);
			
		КонецЕсли;
		
	КонецЦикла;
	
КонецПроцедуры
Заголовок публикации состоит из слитных слов. Разделите их пробелами, если это не общепринятое название и не имя собственное.
TurboConf - расширение Конфигуратора 1С

Похожие публикации

СвернутьМассив (БСП)

РазложитьСтрокуПоискаВМассивСлов (БСП)

ДобавитьУникальноеЗначениеВСписок (БСП)

ЗначениеВМассив (БСП)

ЗаполнитьТаблицуЗначений (БСП)

Модератору