Программное открытие отчета или обработки из справочника "ВнешниеОбработки"

ROXy 25 1 2

Функция открывает внешний отчет или обработку из справочника "ВнешниеОбработки", нужно передать только имя обработки.

Функция ОткрытьВнешнийОтчет(ИмяОтчета) Экспорт
 
    ПутьКВременномуФайлу=КаталогВременныхФайлов()+
"ВременныйФайл" + формат(ТекущаяДата(),"ДФ=ddMMyyyyhhmmss")+ ".tmp";
    о = Справочники.ВнешниеОбработки.НайтиПоНаименованию(ИмяОтчета);
    
    Если о=Справочники.ВнешниеОбработки.ПустаяСсылка() Тогда
        Возврат неопределено;    
    КонецЕсли;
    
    Справочники.ВнешниеОбработки.НайтиПоНаименованию(ИмяОтчета).ХранилищеВнешнейОбработки.Получить().Записать(ПутьКВременномуФайлу);
    
    Если о.ВидОбработки = Перечисления.ВидыДополнительныхВнешнихОбработок.Отчет Тогда
        ВнешниеОтчеты.ПолучитьФорму(ПутьКВременномуФайлу).Открыть();
    КонецЕсли;
    
    Если о.ВидОбработки = Перечисления.ВидыДополнительныхВнешнихОбработок.Обработка Тогда
        ВнешниеОбработки.ПолучитьФорму(ПутьКВременномуФайлу).Открыть();
    КонецЕсли;
    
    УдалитьФайлы(ПутьКВременномуФайлу);
    
    Возврат неопределено;    
    
конецфункции
Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз

Комментарии

romankoav
#1, 06 июля 2020 09:44

А есть БСП шная функция?


Калинин Михаил
#2, 06 июля 2020 14:45

(1) romankoav, я такой не знаю. Поиском тоже не нашел.


Похожие публикации

ЭтоПрофильОткрытиеВнешнихОтчетовИОбработок (БСП)

Программная обработка расшифровки отчета на СКД на обычных формах

ОписаниеПрофиляОткрытиеВнешнихОтчетовИОбработок (БСП)

ОбъектВнешнейОбработки (БСП)

ПодключитьВнешнююОбработку (БСП)

Модератору