Раскрасить даты календаря

ROXy 25 1 2

Процкдура раскрашивает даты в календаре

Процедура ПроизводственныйКалендарьПриВыводеПериода(Элемент, ОформлениеПериода)
	Попытка 
		МассивДат = ПоискДатВРегистреСведениийДатыКурсов ();
		Для Каждого ДатаПериода Из ОформлениеПериода.Даты Цикл
			Если МассивДат.Найти(ДатаПериода.Дата) <> Неопределено Тогда
				ДатаПериода.ЦветФона = webЦвета.БледноЗеленый;
			КонецЕсли;
			Если ДеньНедели(ДатаПериода.Дата)>=6 Тогда
				ДатаПериода.ЦветТекста = webЦвета.Красный; 
			КонецЕсли;
		КонецЦикла;
	Исключение
	КонецПопытки;
КонецПроцедуры
Орфографическая ошибка в Процкдура: Процкдура
Орфографическая ошибка в ПоискДатВРегистреСведениийДатыКурсов: Сведениий
Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз

Похожие публикации

ДатыПоКалендарю (БСП)

ДатаПоКалендарю (БСП)

РазностьДатПоКалендарю (БСП)

Прибавить рабочие дни к дате

ВерсияКалендарей (БСП)

Модератору