Поиск по ГУИД в COM

acsent 84 1 14
Функция НайтиСсылкуНаСправочникПоУИД(СсылкаВБазе, ИмяСправочника, Соединение)
	
	Если НЕ ЗначениеЗаполнено(СсылкаВБазе) Тогда
		Возврат Соединение.Справочники[ИмяСправочника].ПустаяСсылка();
	КонецЕсли;	
	
	УИДСтрокой = Строка(СсылкаВБазе.УникальныйИдентификатор());
	УИД = Соединение.NewObject("УникальныйИдентификатор", УИДСтрокой);
	
	СсылкаНаСправочник = Соединение.Справочники[ИмяСправочника].ПолучитьСсылку(УИД);
	Если Соединение.ОбщегоНазначения.СсылкаСуществует(СсылкаНаСправочник) = Ложь тогда
		Возврат Неопределено;
	КонецЕсли;
	
	Возврат СсылкаНаСправочник; 
	
КонецФункции
0

Рекомендации

См. также

ПараметрыПоиска (БСП)

ВыполнитьПолнотекстовыйПоиск (БСП)

ОсуществитьПоискКонтактовПоСтроке (БСП)

ОпределитьСсылкуПоискаИнформации (БСП)

ИндексПоискаАктуален (БСП)

УстановитьРежимПолнотекстовогоПоиска (БСП)

ПриПолученииРазделовПолнотекстовогоПоиска (БСП)

ПоискКомпонентыНаПорталеПриФормированииРезультата (БСП)

ЗначениеФлажкаИспользоватьПоиск (БСП)

TurboConf - расширение Конфигуратора 1С

Комментарии

Модератору