Разложить строку в массив

freelance_1C 9 1
Функция РазложитьСтрокуВМассивПодстрок(Знач Стр, Разделитель = ",") Экспорт
	МассивСтрок = Новый Массив();
	Если Разделитель = " " Тогда
		Стр = СокрЛП(Стр);
		Пока 1 = 1 Цикл
			Поз = Найти(Стр, Разделитель);
			Если Поз = 0 Тогда
				МассивСтрок.Добавить(Стр);
				Возврат МассивСтрок;
			КонецЕсли;
			МассивСтрок.Добавить(Лев(Стр, Поз - 1));
			Стр = СокрЛ(Сред(Стр, Поз));
		КонецЦикла;
	Иначе
		ДлинаРазделителя = СтрДлина(Разделитель);
		Пока 1 = 1 Цикл
			Поз = Найти(Стр,Разделитель);
			Если Поз = 0 Тогда
				МассивСтрок.Добавить(Стр);
				Возврат МассивСтрок;
			КонецЕсли;
			МассивСтрок.Добавить(Лев(Стр, Поз - 1));
			Стр = Сред(Стр, Поз + ДлинаРазделителя);
		КонецЦикла;
	КонецЕсли;	
КонецФункции
{1} Не все части функции возвращают значение
OneTracker - трекер учета рабочего времени программиста 1С

Комментарии

Combat
#1, 20 сентября 2019 17:09

СтрРазделить(Строка, Разделитель);
СтрСоединить(Строки, Разделитель);


Похожие публикации

РазложитьСтрокуПоТочкамИСлэшам (БСП)

РазложитьСтрокуПоискаВМассивСлов (БСП)

РазложитьСтрокуВМассивПодстрок (БСП)

РазложитьСтрокуВМассивСлов (БСП)

CSV в массив из структур

Модератору