Колонки в строку

prog1c 44 1 5

Возвращает строку с названиями колонок коллекции (ТаблицаЗначений, РезультатЗапроса)

Функция КолонкиВСтроку(Коллекция, Разделитель=",")

	СтрКоллекция = "";
	
	Для каждого Колонка Из Коллекция.Колонки Цикл
		Если Не ПустаяСтрока(СтрКоллекция) Тогда
			СтрКоллекция = СтрКоллекция + Разделитель;
		КонецЕсли;
		СтрКоллекция = СтрКоллекция + Колонка.Имя;
	КонецЦикла;
	
	Возврат СтрКоллекция;

КонецФункции // КолонкиВСтроку()
OneTracker - трекер учета рабочего времени программиста 1С

Похожие публикации

Загрузить колонку (создавать строки Таблицы при необходимости)

Модератору