Колонки в строку

prog1c 49 1 5

Возвращает строку с названиями колонок коллекции (ТаблицаЗначений, РезультатЗапроса)

Функция КолонкиВСтроку(Коллекция, Разделитель=",")

	СтрКоллекция = "";
	
	Для каждого Колонка Из Коллекция.Колонки Цикл
		Если Не ПустаяСтрока(СтрКоллекция) Тогда
			СтрКоллекция = СтрКоллекция + Разделитель;
		КонецЕсли;
		СтрКоллекция = СтрКоллекция + Колонка.Имя;
	КонецЦикла;
	
	Возврат СтрКоллекция;

КонецФункции // КолонкиВСтроку()
FastCode - сервис для программистов 1С

Похожие публикации

ПреобразоватьАдаптированноеНаименованиеКолонкиВСтроку (БСП)

ПреобразоватьСтрокуВДопустимоеНаименованиеКолонки (БСП)

ПутьКТабличнойЧасти (БСП)

ПроверитьДанные (БСП)

НайтиСтрокуВДанныхФормыДерево (БСП)

Модератору