Колонки в строку

prog1c 73 3 5

Возвращает строку с названиями колонок коллекции (ТаблицаЗначений, РезультатЗапроса)

Функция КолонкиВСтроку(Коллекция, Разделитель=",")

	СтрКоллекция = "";
	
	Для каждого Колонка Из Коллекция.Колонки Цикл
		Если Не ПустаяСтрока(СтрКоллекция) Тогда
			СтрКоллекция = СтрКоллекция + Разделитель;
		КонецЕсли;
		СтрКоллекция = СтрКоллекция + Колонка.Имя;
	КонецЦикла;
	
	Возврат СтрКоллекция;

КонецФункции // КолонкиВСтроку()
0

См. также

ПреобразоватьАдаптированноеНаименованиеКолонкиВСтроку (БСП)

ПреобразоватьСтрокуВДопустимоеНаименованиеКолонки (БСП)

ПутьКТабличнойЧасти (БСП)

ПроверитьДанные (БСП)

НайтиСтрокуВДанныхФормыДерево (БСП)

ПриСозданииНаСервереФормыСписка (БСП)

ПриПолученииДанныхНаСервере (БСП)

ИнициализироватьПравилоКонвертацииОбъекта (БСП)

Загрузить колонку (создавать строки Таблицы при необходимости)

Модератору