Таблица значений из списка колонок

prog1c 49 1 5

Создает объект ТаблицаЗначений из списка колонок (строка с разделителями или массив)

Функция ТаблицаЗначений(Колонки)

	Если ТипЗнч(Колонки) = Тип("Строка") Тогда
		Колонки = СтрРазделить(Колонки, ",");
	КонецЕсли;
	
	ТабЗнач = Новый ТаблицаЗначений;
	Для каждого Колонка Из Колонки Цикл
		ИмяКолонки = СтрЗаменить(СокрЛП(Колонка), " ", "_");
		ТабЗнач.Колонки.Добавить(ИмяКолонки);
	КонецЦикла;
	
	Возврат ТабЗнач;

КонецФункции // ТаблицаЗначений()
FastCode - сервис для программистов 1С

Похожие публикации

СформироватьОписаниеКолонок (БСП)

Таблица значений на УФ с динамическим набором колонок

Объединить таблицы значений

Типизированная таблица значений

Создать Таблицу значений со структурой по данным источника

Модератору