Таблица значений из списка колонок

1 prog1c 32 1 5

Создает объект ТаблицаЗначений из списка колонок (строка с разделителями или массив)

Функция ТаблицаЗначений(Колонки)

	Если ТипЗнч(Колонки) = Тип("Строка") Тогда
		Колонки = СтрРазделить(Колонки, ",");
	КонецЕсли;
	
	ТабЗнач = Новый ТаблицаЗначений;
	Для каждого Колонка Из Колонки Цикл
		ИмяКолонки = СтрЗаменить(СокрЛП(Колонка), " ", "_");
		ТабЗнач.Колонки.Добавить(ИмяКолонки);
	КонецЦикла;
	
	Возврат ТабЗнач;

КонецФункции // ТаблицаЗначений()
OneTracker - трекер учета рабочего времени программиста 1С

Похожие публикации

ОбъединитьТаблицыЗначений

Типизированная таблица значений

Сохранение таблицы значений в XML

ТаблицаЗначенийВТаблицуХТМЛ

Поиск в таблице значений неуникальных значений

Модератору