Таблица значений из списка колонок

prog1c 95 4 6

Создает объект ТаблицаЗначений из списка колонок (строка с разделителями или массив)

Функция ТаблицаЗначений(Колонки)

	Если ТипЗнч(Колонки) = Тип("Строка") Тогда
		Колонки = СтрРазделить(Колонки, ",");
	КонецЕсли;
	
	ТабЗнач = Новый ТаблицаЗначений;
	Для каждого Колонка Из Колонки Цикл
		ИмяКолонки = СтрЗаменить(СокрЛП(Колонка), " ", "_");
		ТабЗнач.Колонки.Добавить(ИмяКолонки);
	КонецЦикла;
	
	Возврат ТабЗнач;

КонецФункции // ТаблицаЗначений()
0

См. также

СформироватьОписаниеКолонок (БСП)

Таблица значений на УФ с динамическим набором колонок

Объединить таблицы значений

Функция копирования колонок в таблицу или дерево значений (конструктор таблиц и деревьев значений)

Выбрать Файл Excel и преобразовать в Таблицу значений

Типизированная таблица значений

Создать Таблицу значений со структурой по данным источника

Таблица Значений Без Null

Получить выделенные строки списка (с сохранением выделения)

Модератору