Таблица значений из списка колонок

prog1c 60 2 5

Создает объект ТаблицаЗначений из списка колонок (строка с разделителями или массив)

Функция ТаблицаЗначений(Колонки)

	Если ТипЗнч(Колонки) = Тип("Строка") Тогда
		Колонки = СтрРазделить(Колонки, ",");
	КонецЕсли;
	
	ТабЗнач = Новый ТаблицаЗначений;
	Для каждого Колонка Из Колонки Цикл
		ИмяКолонки = СтрЗаменить(СокрЛП(Колонка), " ", "_");
		ТабЗнач.Колонки.Добавить(ИмяКолонки);
	КонецЦикла;
	
	Возврат ТабЗнач;

КонецФункции // ТаблицаЗначений()
0

Рекомендации

См. также

СформироватьОписаниеКолонок (БСП)

Таблица значений на УФ с динамическим набором колонок

Объединить таблицы значений

Типизированная таблица значений

Создать Таблицу значений со структурой по данным источника

Таблица Значений Без Null

Получить выделенные строки списка (с сохранением выделения)

ЗначенияСписком (БСП)

СкопироватьРекурсивно (БСП)

TurboConf - расширение Конфигуратора 1С

Комментарии

Модератору