УдалитьСтрокиТаблицыЗначений

prog1c 44 1 5

Удаляет строки ТЗ, соответсвующие структуре отбора

Функция УдалитьСтрокиТаблицыЗначений(Знач Таблица, СтруктураОтбора) Экспорт
	
	МассивСтрок = Новый Массив;
	РезультатОтбора = Таблица.НайтиСтроки(СтруктураОтбора);
	Для каждого СтрокаОтбора Из РезультатОтбора Цикл
		МассивСтрок.Добавить(СтрокаОтбора);
	КонецЦикла;
	
	Для Каждого СтрокаТЗ Из МассивСтрок Цикл
		Таблица.Удалить(СтрокаТЗ);
	КонецЦикла;
	
    Возврат Таблица;
    
КонецФункции // УдалитьСтрокиТаблицыЗначений()
Орфографическая ошибка в соответсвующие: соответсвующие
Заголовок публикации состоит из слитных слов. Разделите их пробелами, если это не общепринятое название и не имя собственное.
FastCode Professional - быстрый поиск кода 1С

Похожие публикации

Удалить дубли строк в таблице значений

Описание строки в таблице значений

Отбор по таблице значений

Преобразовать строку таблицы значений в структуру

Удаление строк таблицы по условию

Модератору