УдалитьСтрокиТаблицыЗначений

prog1c 59 2 5

Удаляет строки ТЗ, соответсвующие структуре отбора

Функция УдалитьСтрокиТаблицыЗначений(Знач Таблица, СтруктураОтбора) Экспорт
	
	МассивСтрок = Новый Массив;
	РезультатОтбора = Таблица.НайтиСтроки(СтруктураОтбора);
	Для каждого СтрокаОтбора Из РезультатОтбора Цикл
		МассивСтрок.Добавить(СтрокаОтбора);
	КонецЦикла;
	
	Для Каждого СтрокаТЗ Из МассивСтрок Цикл
		Таблица.Удалить(СтрокаТЗ);
	КонецЦикла;
	
    Возврат Таблица;
    
КонецФункции // УдалитьСтрокиТаблицыЗначений()
0
Орфографическая ошибка в соответсвующие: соответсвующие
Заголовок публикации состоит из слитных слов. Разделите их пробелами, если это не общепринятое название и не имя собственное.

Рекомендации

См. также

Удалить дубли строк в таблице значений

Описание строки в таблице значений

Отбор по таблице значений

Преобразовать строку таблицы значений в структуру

СтрокаТаблицыЗначенийВСтруктуру (БСП)

Удаление строк таблицы по условию

ОставитьСтрокиТаблицыЗначений

Получить выделенные строки списка (с сохранением выделения)

Свернуть строки в таблице значений конкатенацией

TurboConf - расширение Конфигуратора 1С

Комментарии

Модератору