ОставитьСтрокиТаблицыЗначений

prog1c 44 1 5

Оставляет строки ТаблицыЗначений, соответсвующие структуре отбора (удаляет не соответсвующие)

Функция ОставитьСтрокиТаблицыЗначений(Знач Таблица, СтруктураОтбора) Экспорт
	
	МассивСтрок = Новый Массив;
	РезультатОтбора = Таблица.НайтиСтроки(СтруктураОтбора);
	Для каждого СтрокаОтбора Из РезультатОтбора Цикл
		МассивСтрок.Добавить(СтрокаОтбора);
	КонецЦикла;
	
	МассивУдаления = Новый Массив;
	Для Каждого СтрокаТЗ Из Таблица Цикл
		Если МассивСтрок.Найти(СтрокаТЗ) = Неопределено Тогда
			МассивУдаления.Добавить(СтрокаТЗ);
		КонецЕсли;
	КонецЦикла;
	
	Для Каждого СтрокаТЗ Из МассивУдаления Цикл
		Таблица.Удалить(СтрокаТЗ);
	КонецЦикла;
	
    Возврат Таблица;
    
КонецФункции // ОставитьСтрокиТаблицыЗначений()
Орфографическая ошибка в соответсвующие (найдено 2): соответсвующие
Заголовок публикации состоит из слитных слов. Разделите их пробелами, если это не общепринятое название и не имя собственное.
TurboConf - расширение Конфигуратора 1С

Похожие публикации

Описание строки в таблице значений

Отбор по таблице значений

Преобразовать строку таблицы значений в структуру

Удаление строк таблицы по условию

УдалитьСтрокиТаблицыЗначений

Модератору