ОставитьСтрокиТаблицыЗначений

prog1c 58 1 6

Оставляет строки ТаблицыЗначений, соответсвующие структуре отбора (удаляет не соответсвующие)

Функция ОставитьСтрокиТаблицыЗначений(Знач Таблица, СтруктураОтбора) Экспорт
	
	МассивСтрок = Новый Массив;
	РезультатОтбора = Таблица.НайтиСтроки(СтруктураОтбора);
	Для каждого СтрокаОтбора Из РезультатОтбора Цикл
		МассивСтрок.Добавить(СтрокаОтбора);
	КонецЦикла;
	
	МассивУдаления = Новый Массив;
	Для Каждого СтрокаТЗ Из Таблица Цикл
		Если МассивСтрок.Найти(СтрокаТЗ) = Неопределено Тогда
			МассивУдаления.Добавить(СтрокаТЗ);
		КонецЕсли;
	КонецЦикла;
	
	Для Каждого СтрокаТЗ Из МассивУдаления Цикл
		Таблица.Удалить(СтрокаТЗ);
	КонецЦикла;
	
    Возврат Таблица;
    
КонецФункции // ОставитьСтрокиТаблицыЗначений()
0
Орфографическая ошибка в соответсвующие (найдено 2): соответсвующие
Заголовок публикации состоит из слитных слов. Разделите их пробелами, если это не общепринятое название и не имя собственное.

Рекомендации

См. также

Описание строки в таблице значений

Отбор по таблице значений

Преобразовать строку таблицы значений в структуру

СтрокаТаблицыЗначенийВСтруктуру (БСП)

Удаление строк таблицы по условию

УдалитьСтрокиТаблицыЗначений

Свернуть строки в таблице значений конкатенацией

Объединить таблицы значений

Удалить дубли строк в таблице значений

TurboConf - расширение Конфигуратора 1С

Комментарии

Модератору