ОбъединитьТаблицыЗначений

4 prog1c 32 1 5

Ищет в таблице значений строки, соответсвующие значениям колонок Измерения и складывает значения колонок Ресурсы. Если строка не найдена, то добавляется новая.

Функция ОбъединитьТаблицыЗначений(Знач Таблица1, Таблица2, Измерения, Ресурсы) Экспорт
	
	МассивРесурсов = СтрРазделить(Ресурсы, ",");
	СтруктураОтбора = Новый Структура(Измерения);
	Для Каждого СтрокаТЗ Из Таблица2 Цикл
		
		ЗаполнитьЗначенияСвойств(СтруктураОтбора, СтрокаТЗ);
		
		РезультатОтбора = Таблица1.НайтиСтроки(СтруктураОтбора);
		Если РезультатОтбора.Количество() > 0 Тогда
			СтрокаОтбора = РезультатОтбора[0];
			Для Каждого Колонка Из МассивРесурсов Цикл
				СтрокаОтбора[Колонка] = СтрокаОтбора[Колонка] + СтрокаТЗ[Колонка];
			КонецЦикла;
		Иначе
			СтрокаОтбора = Таблица1.Добавить();
			ЗаполнитьЗначенияСвойств(СтрокаОтбора, СтрокаТЗ);
		КонецЕсли;
		
	КонецЦикла;
	
	Возврат Таблица1;
	
КонецФункции
Орфографическая ошибка в соответсвующие: соответсвующие
Заголовок публикации состоит из слитных слов. Разделите их пробелами, если это не общепринятое название и не имя собственное.
Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз

Похожие публикации

Определить элементарные интервалы, образующиеся при пересечении всех исходных интервалов

Сохранение таблицы значений в XML

ТаблицаЗначенийВТаблицуХТМЛ

Поиск в таблице значений неуникальных значений

Дополнить таблицу значений - приемника данными из таблицы значений - источника

Модератору