Убрать лишние символы из строки

Igozz 24 1 2

Возвращает строку, состоящую только из цифр и символов русского и английского алфавита

Функция УбратьЛишниеСимволыИзСтроки(Строка) Экспорт
	РезультирующаяСтрока = "";
	Для н = 1 По СтрДлина(Строка) Цикл
		Если (КодСимвола(Строка, н) >= 48 И КодСимвола(Строка, н) <= 57)
			ИЛИ (КодСимвола(Строка, н) >= 65 И КодСимвола(Строка, н) <= 90)
			ИЛИ (КодСимвола(Строка, н) >= 97 И КодСимвола(Строка, н) <= 122)
			ИЛИ (КодСимвола(Строка, н) >= 1040 И КодСимвола(Строка, н) <= 1103) Тогда
			РезультирующаяСтрока = РезультирующаяСтрока + Сред(Строка, н, 1);
		КонецЕсли;
	КонецЦикла;
	Возврат РезультирующаяСтрока;
КонецФункции
0

Рекомендации

См. также

ЗаменитьНедопустимыеСимволыXML (БСП)

УдалитьНедопустимыеСимволыXML (БСП)

ЗаменитьОдниСимволыДругими (БСП)

УдалитьПоследниеСимволыИзСтроки (БСП)

ПроверитьСтрокуНаЗапрещенныеСимволы (БСП)

УдалитьПоследнийСимволВСтроке (БСП)

СформироватьСтрокуСимволов (БСП)

ПолучитьНедопустимыеСимволыВИмениФайла (БСП)

УдалитьПовторяющиесяСимволы (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз

Комментарии

Модератору