ip адрес локального компьютера

buketoff 96 1 1 10

узнать ip адрес локального компьютера

&НаКлиенте
Процедура УзнатьIP(Команда)
	
	COMОбъект1 = Новый COMОбъект("WbemScripting.SWbemLocator");
	COMОбъект2 = COMОбъект1.ConnectServer(".","root\CIMV2");
	
	Результат = COMОбъект2.ExecQuery("SELECT IPAddress FROM 
	|Win32_NetworkAdapterConfiguration 
	|WHERE IPEnabled = TRUE");
	
	Для каждого Строка Из Результат Цикл
		Для каждого ПодСтрока Из Строка.IPAddress Цикл 
			Стр = Объект.IPAddress.Добавить();
			Стр.Адрес = ПодСтрока;
			//Сообщить(ПодСтрока);
		КонецЦикла;
	КонецЦикла;
	
КонецПроцедуры
0

Рекомендации

См. также

УстановитьИдентификаторыАдреса (БСП)

АдресПубликацииИнформационнойБазыВЛокальнойСети (БСП)

ПолучитьСертификатПоОтпечатку (БСП)

ПредставлениеЛокальнойДатыСоСмещением (БСП)

АдресЕАЭС (БСП)

ОткрытьКаталогФайла (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз

Комментарии

Модератору