МассивВТаблицуЗначений

prog1c 44 1 5

Преобразует массив в ТаблицуЗначений

Функция МассивВТаблицуЗначений(ИсходныйМассив, Знач ИмяКолонки="") Экспорт
	
	Если ПустаяСтрока(ИмяКолонки) Тогда
		ИмяКолонки = "Колонка1";
	КонецЕсли;
	
	ИмяКолонки = СтрЗаменить(ИмяКолонки, " ", "_");
	
	Результат = Новый ТаблицаЗначений;
	Результат.Колонки.Добавить(ИмяКолонки);
	
	Если ЗначениеЗаполнено(ИсходныйМассив) Тогда
		Для Сч = 1 По ИсходныйМассив.Количество() Цикл
			Результат.Добавить();
		КонецЦикла;
		Результат.ЗагрузитьКолонку(ИсходныйМассив, ИмяКолонки);
	КонецЕсли;
	
	Возврат Результат;	

КонецФункции // МассивВТаблицуЗначений()
Заголовок публикации состоит из слитных слов. Разделите их пробелами, если это не общепринятое название и не имя собственное.
FastCode Professional - быстрый поиск кода 1С

Похожие публикации

Преобразовать таблицу значений в массив

ТаблицаЗначенийВМассив

Преобразовать массив структур в ТаблицуЗначений

Выгрузить Таблицу значений в массив структур (для передачи сервер - клиент)

Таблица значений из списка колонок

Модератору