МассивБезДублей

prog1c 44 1 5

Убирает дубли из массива значений

Функция МассивБезДублей(ИсходныйМассив) Экспорт

	Результат = Новый Массив;
	
	Если ЗначениеЗаполнено(ИсходныйМассив) Тогда
		ВремТаб = Новый ТаблицаЗначений;
		ВремТаб.Колонки.Добавить("Данные");
		Для Сч = 1 По ИсходныйМассив.Количество() Цикл
			ВремТаб.Добавить();
		КонецЦикла;
		ВремТаб.ЗагрузитьКолонку(ИсходныйМассив, 0);
		ВремТаб.Свернуть(ВремТаб.Колонки[0].Имя);
		Результат = ВремТаб.ВыгрузитьКолонку(0);
	КонецЕсли;
	
	Возврат Результат;	

КонецФункции // МассивБезДублей()
Заголовок публикации состоит из слитных слов. Разделите их пробелами, если это не общепринятое название и не имя собственное.
FastCode Professional - быстрый поиск кода 1С

Комментарии

Borzyj
#1, 26 февраля 2020 12:07

А чем не устраивают методы БСП?


prog1c
#2, 11 марта 2020 05:32

(1) Borzyj, на больших данных работает гораздо быстрее чем перебор.


Похожие публикации

Удалить дубли строк в таблице значений

Количество дублей элементов справочника

Дополнить массив МассивПриемник значениями из массива МассивИсточник

Разложить строку в массив

Модератору