МассивБезДублей

prog1c 58 1 6

Убирает дубли из массива значений

Функция МассивБезДублей(ИсходныйМассив) Экспорт

	Результат = Новый Массив;
	
	Если ЗначениеЗаполнено(ИсходныйМассив) Тогда
		ВремТаб = Новый ТаблицаЗначений;
		ВремТаб.Колонки.Добавить("Данные");
		Для Сч = 1 По ИсходныйМассив.Количество() Цикл
			ВремТаб.Добавить();
		КонецЦикла;
		ВремТаб.ЗагрузитьКолонку(ИсходныйМассив, 0);
		ВремТаб.Свернуть(ВремТаб.Колонки[0].Имя);
		Результат = ВремТаб.ВыгрузитьКолонку(0);
	КонецЕсли;
	
	Возврат Результат;	

КонецФункции // МассивБезДублей()
2
Заголовок публикации состоит из слитных слов. Разделите их пробелами, если это не общепринятое название и не имя собственное.

Рекомендации

См. также

Удаление дублей договоров в 1С

НайтиДублиЭлемента (БСП)

Удалить дубли строк в таблице значений

Количество дублей элементов справочника

ИмяФормыОбработкиПоискИУдалениеДублей (БСП)

МаксимальноеКоличествоПолейСопоставленияОбъектов (БСП)

СкопироватьМассив (БСП)

ЗначениеВМассив (БСП)

Разложить строку в массив

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз

Комментарии

Borzyj
#1, 26 февраля 2020 12:07

А чем не устраивают методы БСП?


prog1c
#2, 11 марта 2020 05:32

(1) Borzyj, на больших данных работает гораздо быстрее чем перебор.


Модератору