Оформление (раскраска) строки табличной части обычной формы по условию, при получении данных

pkonev 4 1

Событие ПриПолученииДанных используется для оформления ячеек строк данных, отображаемых табличным полем. В нем можно оформить или раскрасить строку, в зависимости от данных.

Процедура ТоварыПриПолученииДанных(Элемент, ОформленияСтрок)
		
	Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
			
		Если ОформлениеСтроки.ДанныеСтроки.Товар.Уценен Тогда
			ОформлениеСтроки.Ячейки.Комментарий.УстановитьТекст("Уценка");
			ОформлениеСтроки.Ячейки.Комментарий.ЦветФона = Новый Цвет(255, 255, 128);
			ОформлениеСтроки.Ячейки.Комментарий.ЦветТекста = Новый Цвет(0, 0, 0);
			ОформлениеСтроки.Ячейки.Комментарий.ТолькоПросмотр = Истина;
		КонецЕсли;
				
		//ОформлениеСтроки.ЦветФона = Новый Цвет(255, 255, 128);
		//ОформлениеСтроки.ЦветТекста = Новый Цвет(0, 0, 0);
						
	КонецЦикла;
	
КонецПроцедуры
0

Рекомендации

См. также

Раскраска строки табличной части документа (обычные формы) по условию

пересчет реквизита табличной части обычной формы

Заполнение "пустых" строк табличной части

Условное оформление на обычных формах (ОФ)

Расчет суммы в строке табличной части

ПоказатьФормуЗагрузки (БСП)

Изменение видимости колонок табличной части по параметру свойству таблицы "ПланыВидовРасчета"

ПоказатьФормуЗаполненияСсылок (БСП)

Поведение СКД при формировании табличного документа с использованием макета для оформления

TurboConf - расширение Конфигуратора 1С

Комментарии

Модератору