Запуск отчета из документа, передача ссылки в параметр отчета

//Создаем команду в документе, в команде прописываем..
СтруктураПараметров = Новый Структура;
СтруктураПараметров.Вставить("ИМЯКОМАНДЫ", Объект.Ссылка);
	
ОткрытьФорму("Отчет.НАИМЕНОВАНИЕОТЧЕТА.Форма.ФормаОтчета", СтруктураПараметров, Объект.Ссылка);

//В модуле формы отчета:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	Параметры.СформироватьПриОткрытии = Истина;
КонецПроцедуры

&НаСервере
Процедура ПередЗагрузкойВариантаНаСервере(Настройки)
	Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("ИМЯКОМАНДЫ", Параметры.ИМЯКОМАНДЫ);   
КонецПроцедуры

&НаСервере
Процедура ПриЗагрузкеПользовательскихНастроекНаСервере(Настройки, ИспользуютсяСтандартныеНастройки)
	Параметр = Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("ИМЯКОМАНДЫ");
	Параметр.Значение = Параметры.ИМЯКОМАНДЫ;            
	Параметр.Использование = Истина; 
КонецПроцедуры
TurboConf - расширение Конфигуратора 1С

Похожие публикации

ЭтоЗадачаИсполнителю (БСП)

ПараметрыФормыОтправкиSMS (БСП)

ПриДобавленииПараметровРаботыКлиентаПриЗапуске (БСП)

ПараметрыЗапускаПрограммы (БСП)

ПриОбработкеПараметровЗапуска (БСП)

Модератору