Сведения о внешней обработке - Печать

2 reborn85 17 3

Сведения о внешней печатной формы для использования совместно с БСП

#Область ОсновныеНастройкиДляПодключенияПечать
Функция ВернутьСтруктуруПараметров()
	
	Структура = Новый Структура();
	Структура.Вставить("Документ","Документ.АктОРасхожденияхПриПоступленииТоваров");
	Структура.Вставить("Представление",ЭтотОбъект.Метаданные().Представление());
	Структура.Вставить("Наименование",ЭтотОбъект.Метаданные().Синоним);
	Структура.Вставить("Идентификатор",ЭтотОбъект.Метаданные().Имя);
	Структура.Вставить("Версия","1.0.0.0");
	Возврат Структура;	
	
КонецФункции 


Функция	СведенияОВнешнейОбработке() ЭКСПОРТ
	
	Структура = ВернутьСтруктуруПараметров();
	Версия = СтандартныеПодсистемыСервер.ВерсияБиблиотеки();
	Сведения = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке(Версия);
	Сведения.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиПечатнаяФорма();
	Сведения.Версия = Структура.Версия;
	
	МассивНазначений = Новый Массив();
	МассивНазначений.Добавить(Структура.Документ);
	Сведения.Назначение = МассивНазначений;
	Сведения.Наименование = Структура.Наименование;
	
	стр = Сведения.Команды.Добавить();
	стр.Представление = Структура.Представление;
	стр.Идентификатор = Структура.Идентификатор;
	стр.Модификатор	  = "ПечатьMXL";
	стр.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();	
	Возврат Сведения;
	
КонецФункции

Функция Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) ЭКСПОРТ
	
	Структура = ВернутьСтруктуруПараметров();
	
	Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, Структура.Идентификатор) Тогда
		УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, Структура.Идентификатор, Структура.Представление, СформироватьПечатнуюФорму(МассивОбъектов, ОбъектыПечати));
	КонецЕсли;
	
КонецФункции

Функция СформироватьПечатнуюФорму(МассивОбъектов, ОбъектыПечати)
	
	ТабличныйДокумент = Новый ТабличныйДокумент;
	
	
	Возврат ТабличныйДокумент;
	
КонецФункции
#КонецОбласти
{37} Не все части функции возвращают значение
FastCode Professional - быстрый поиск кода 1С

Похожие публикации

Сведения о внешней обработке - Отчет

Отладить внешнюю обработку

Модератору