Использование Синонима отчета/обработки при выполнении кода &НаКлиенте

buketoff 17 3

Для использования синонима отчета/обработки при исполнении на клиенте для подобной универсальной подстановки в разные места - можно завести реквизит формы СинонимОтчета (тип Строка), заполнять его в ПриСозданииНаСервере() этой формы и потом обращаться к нему Форма.СинонимОтчета.

//***********************************************************************
&НаКлиенте
Процедура СохранитьВExcel(Команда)
    
    ИмяФайла = Форма.СинонимОтчета + " (" + 
    Строка(Формат(ТекущаяДата(),"ДФ=""дд-ММ-гггг""")) + ")" 
    +".xlsx";
    
    //.....

КонецПроцедуры

&НаКлиентеНаСервереБезКонтекста
Процедура ОбновитьТекстЗаголовка(Форма)
    
    Отчет = Форма.Отчет;
    
    ЗаголовокОтчета = НСтр("ru = '" + Форма.СинонимОтчета + "'") + БухгалтерскиеОтчетыКлиентСервер.ПолучитьПредставлениеПериода(Отчет.НачалоПериода, Отчет.КонецПериода);

    Если ЗначениеЗаполнено(Отчет.Организация) И Форма.ИспользуетсяНесколькоОрганизаций Тогда
        ЗаголовокОтчета = ЗаголовокОтчета + " " + БухгалтерскиеОтчетыВызовСервераПовтИсп.ПолучитьТекстОрганизация(Отчет.Организация, Отчет.ВключатьОбособленныеПодразделения);
    КонецЕсли;
    
    Форма.Заголовок = ЗаголовокОтчета;

КонецПроцедуры

//***********************************************************************
&НаСервере
Функция ВернутьСинонимОтчета()
    
    ОтчетОбъект = РеквизитФормыВЗначение("Отчет");
    
    Возврат ОтчетОбъект.Метаданные().Синоним + " " + ОтчетОбъект.Метаданные().Комментарий;
    //Возврат ОтчетОбъект.Метаданные().Синоним;
    
КонецФункции
//***********************************************************************

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    ЭтаФорма.СинонимОтчета = ВернутьСинонимОтчета();

КонецПроцедуры
{7} Переменной ИмяФайла присвоено значение, но оно нигде не используется
FastCode Professional - быстрый поиск кода 1С

Похожие публикации

Пауза, ожидание в коде

Модератору