Проверка заполненности сложных объектов

Проверяет, содержит ли переменная или коллекция какие-либо данные

Функция СодержитДанные(ЗначениеДляПроверки) Экспорт
	Результат = Ложь;
	
	Если ЗначениеДляПроверки <> Неопределено Тогда
		Если ТипЗнч(ЗначениеДляПроверки) = Тип("ТаблицаЗначений")
			Или ТипЗнч(ЗначениеДляПроверки) = Тип("Массив") 
			Или ТипЗнч(ЗначениеДляПроверки) = Тип("СписокЗначений") 
			Тогда
			
			Если ЗначениеДляПроверки.Количество() > 0 Тогда
				Результат = Истина;
			КонецЕсли;
			
		Иначе
			Результат = ЗначениеЗаполнено(ЗначениеДляПроверки);
		КонецЕсли
		
	КонецЕсли;
	
	Возврат Результат;
КонецФункции 
0

Рекомендации

См. также

Проверка заполнения на клиенте

ОбработкаПроверкиЗаполнения (БСП)

Проверка заполненности полей объекта и возврат статуса + незаполненных полей

ВидОбработкиЗаполнениеОбъекта (БСП)

ПроверкаЗаполненностиРеквизитовОтложеннойОтправки (БСП)

ОбработкаПроверкиЗаполненияПрисоединенногоФайла (БСП)

ОбработкаПроверкиЗаполненияНаСервере (БСП)

Ищу универсальный метод проверки заполненности мутабельного значения

ОбъектыСКомандамиЗаполнения (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз

Комментарии

Модератору