Программное добавление нового пользователя

Iyad1020 6 1

Программное добавление нового пользователя в базу, в которой используется стандартная подсистема "Пользователи" БСП.

Процедура СоздатьНовогоПользователя(Имя, Пароль)
    
    ПроверкаНаСуществующегоПользователя = ПользователиИнформационнойБазы.НайтиПоИмени(Имя);
    
    Если ПроверкаНаСуществующегоПользователя = Неопределено Тогда
        
        ОписаниеПользователяИБ = Пользователи.НовоеОписаниеПользователяИБ();
        
        //В списке выбора не показываем
        ОписаниеПользователяИБ.ПоказыватьВСпискеВыбора = Ложь;
        
        ОписаниеПользователяИБ.АутентификацияСтандартная = Истина;            
        
        ОписаниеПользователяИБ.Вставить("Действие", "Записать");
        ОписаниеПользователяИБ.Имя = Имя;
        ОписаниеПользователяИБ.Пароль = Пароль;
        
        
        НовыйПользователь = Справочники.Пользователи.СоздатьЭлемент();
        НовыйПользователь.Имя    = Имя;
        НовыйПользователь.Код             = Имя;
        НовыйПользователь.Недействителен  = ложь;
        
        НовыйПользователь.ДополнительныеСвойства.Вставить(
            "ОписаниеПользователяИБ", ОписаниеПользователяИБ);
        
        Попытка
            НовыйПользователь.Записать();            
            ДобавитьРолиНовомуПользователю(НовыйПользователь.Имя);
       	Исключение
            ОбщегоНазначенияКлиентСервер.СообщитьПользователю("Ошибка создания нового пользователя" + ОписаниеОшибки());
        КонецПопытки;
        
    КонецЕсли;
        
    
КонецПроцедуры

Процедура ДобавитьРолиНовомуПользователю(Имя);
    Пользователь = ПользователиИнформационнойБазы.НайтиПоИмени(Имя);
    Пользователь.Роли.Добавить(Метаданные.Роли.АдминистраторСистемы);
    Пользователь.Роли.Добавить(Метаданные.Роли.ПолныеПрава);
    Пользователь.Записать();
КонецПроцедуры
OneTracker - трекер учета рабочего времени программиста 1С

Похожие публикации

НовыйПараметрыДобавленияПользователяВПриложение (БСП)

ДоступноПравоДобавленияУчетныхЗаписей (БСП)

Программное добавление возможности отбора в динамический список формы

ПриАвторизацииНовогоПользователяИБ (БСП)

ОткрытьСтраницуРегистрацииНовогоПользователя (БСП)

Модератору