Выгрузить Таблицу значений в массив структур (для передачи сервер - клиент)

СергейТ 9 1

Для передачи таблицы значений с сервера на клиент нельзя использовать объект типа таблица значений. Нужно преобразовывать таблицу в массив структур. Функция для преобразования Таблицы значений (ТаблицаЗначений) в массив структур.

&НаСервереБезКонтекста
Функция ТаблицуЗначенийВМассив(ТаблЗнач)
	Результат=Новый Массив;
	Для Каждого ТекСтр Из ТаблЗнач Цикл
		СтруктураСтроки=Новый Структура;
		Для Каждого ТекКол Из ТаблЗнач.Колонки Цикл
			СтруктураСтроки.Вставить(ТекКол.Имя,ТекСтр[ТекКол.Имя])
		КонецЦикла;
		Результат.Добавить(СтруктураСтроки)
	КонецЦикла;
	Возврат Результат
КонецФункции
Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз

Комментарии

Калинин Михаил
#1, 13 июля 2020 13:42

Шаблон называется "Выгрузить Таблицу значений в запрос", а описана выгрузка в массив структур?


СергейТ
#2, 13 июля 2020 15:30

(1) Калинин Михаил, Сорян. Сначала писал один заголовок, потом подправил, но не полностью. Спасибо. Исправил.


Похожие публикации

Выгрузка Таблицы значений в Объект Таблица Значений на форме обработки (для передачи сервер - клиент)

ТаблицаЗначенийВМассив (БСП)

Преобразовать массив структур в ТаблицуЗначений

СортироватьМассивСтруктур (БСП)

Преобразовать таблицу значений в массив

Модератору