Выгрузить Таблицу значений в массив структур (для передачи сервер - клиент)

СергейТ 103 4 9

Для передачи таблицы значений с сервера на клиент нельзя использовать объект типа таблица значений. Нужно преобразовывать таблицу в массив структур. Функция для преобразования Таблицы значений (ТаблицаЗначений) в массив структур.

&НаСервереБезКонтекста
Функция ТаблицуЗначенийВМассив(ТаблЗнач)
	Результат=Новый Массив;
	Для Каждого ТекСтр Из ТаблЗнач Цикл
		СтруктураСтроки=Новый Структура;
		Для Каждого ТекКол Из ТаблЗнач.Колонки Цикл
			СтруктураСтроки.Вставить(ТекКол.Имя,ТекСтр[ТекКол.Имя])
		КонецЦикла;
		Результат.Добавить(СтруктураСтроки)
	КонецЦикла;
	Возврат Результат
КонецФункции
6

Комментарии

Калинин Михаил
#1, 13 июля 2020 13:42

Шаблон называется "Выгрузить Таблицу значений в запрос", а описана выгрузка в массив структур?


СергейТ
#2, 13 июля 2020 15:30

(1) Калинин Михаил, Сорян. Сначала писал один заголовок, потом подправил, но не полностью. Спасибо. Исправил.


prog1c
#3, 21 апреля 2022 09:03

Хорошо бы добавить и обратную функцию - ТаблицаЗначенийИзМассиваСтруктур ))


СергейТ
#4, 13 сентября 2022 15:11

(3) prog1c, Если не нужны сортировки и поиски, то в этом нет необходимости. Однако, согласен, просто мне не потребовалось.


Little Friend
#5, 29 марта 2024 16:42

Так-то поэффективней будет (без цикла в цикле).

Функция ТаблицаЗначенийВМассивСтруктур(ТаблицаЗначений)
	МассивКолонок = Новый Массив;
	Для каждого Колонка Из ТаблицаЗначений.Колонки Цикл
		МассивКолонок.Добавить(Колонка.Имя);
	КонецЦикла;
	Колонки = СтрСоединить(МассивКолонок, ",");
	
	Результат = Новый Массив;
	
	Для каждого СтрокаТаблицы Из ТаблицаЗначений Цикл
		СтрокаТаблицыСтруктурой = Новый Структура(Колонки);
		ЗаполнитьЗначенияСвойств(СтрокаТаблицыСтруктурой, СтрокаТаблицы);
		Результат.Добавить(СтрокаТаблицыСтруктурой);
	КонецЦикла;
	
	Возврат Результат;
КонецФункции


СергейТ
#6, 04 апреля 2024 11:45

(5) Little Friend, Не дошли руки поправить ))


См. также

Выгрузка Таблицы значений в Объект Таблица Значений на форме обработки (для передачи сервер - клиент)

ТаблицаЗначенийВМассив (БСП)

Преобразовать массив структур в ТаблицуЗначений

Функция преобразует Массив из структур в ТаблицуЗначений

СортироватьМассивСтруктур (БСП)

Выгрузить динамический список в таблицу значений

МассивСтруктурВТаблицуЗначений

ТаблицаЗначенийВМассивСтруктур

Работа с универсальными коллекциями данных

Модератору