Проверка типа данных на принадлежность к ссылочным типам

Проверяет тип (ОписаниеТипов) на принадлежность к ссылочным - может понадобиться при Сериализации/Десериализации данных для ИБ с различной структурой

Функция ЭтоТипСсылка(ТипДанных, ВсеТипыСсылок = Неопределено) Экспорт
    Результат = Ложь;
    
    Если ВсеТипыСсылок = Неопределено Тогда
        ВсеТипыСсылок = ОписаниеТипаВсеСсылки();
    КонецЕсли;
    
    Если ТипЗнч(ТипДанных) = Тип("ОписаниеТипов") Тогда
        ТипыВнутри = ТипДанных.Типы();
        Для каждого Тип Из ТипыВнутри Цикл
            Если ВсеТипыСсылок.СодержитТип(Тип) Тогда
                Результат = Истина;
            КонецЕсли;
        КонецЦикла;
    Иначе 
        Если ВсеТипыСсылок.СодержитТип(ТипДанных) Тогда
            Результат = Истина;
        КонецЕсли;
    КонецЕсли;
    
    Возврат Результат;
КонецФункции
FastCode Professional - быстрый поиск кода 1С
Модератору