Проверка, есть ли ключ у соответствия

CerbeRUS 2
Функция ЕстьКлючСоответствия(Объект, Ключ) Экспорт
  Если Объект[Ключ] <> Неопределено Тогда
    Возврат Истина;
  КонецЕсли;
  До = Объект.Количество();
  Объект.Вставить(Ключ);
  После = Объект.Количество();
  Если До <> После Тогда
    Объект.Удалить(Ключ);
  КонецЕсли;
  Возврат До = После;
КонецФункции
Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз

Комментарии

Ruizave
#1, ред. 25 августа 2020 15:56

А для чего вставка и проверка количества? Вхождение же уже проверили на этапе получения ключа?


bolsun
#2, 25 августа 2020 16:03

(1) Ruizave, на тот случай, если ключ в соответствии есть, но содержит значение Неопределено.


Похожие публикации

Перенести коллекцию КлючИЗначение

Модератору