Стандартное формирование выборок

Функция Наименование1(МассивОбъектов, ПараметрыПечати)
	
	Запрос = Новый Запрос;
	Запрос.УстановитьПараметр("Ссылка", МассивОбъектов[0]);
	
	Запрос.Текст =
	"ВЫБРАТЬ
	
	
	Возврат Запрос.Выполнить();	
		
КонецФункции

Функция Наименование2(МассивОбъектов, ПараметрыПечати, ОбъектыПечати)
	
	Макет = ПолучитьМакет("Макет");
	
	НастройкиПечатныхФорм = ЗарплатаКадрыПовтИсп.НастройкиПечатныхФорм();
	
	ДокументРезультат = Новый ТабличныйДокумент;
	
	ДокументРезультат.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_Приказ";
	ДокументРезультат.ОриентацияСтраницы= ОриентацияСтраницы.Портрет;
	ДокументРезультат.АвтоМасштаб = Истина;
	
	ВалютаУчета = ЗарплатаКадры.ВалютаУчетаЗаработнойПлаты();
	
	ОбластьМакета = Макет.ПолучитьОбласть("ОбластьМакета");
	
	// получаем данные для печати
	ДанныеДляПечати = Наименование1(МассивОбъектов, ПараметрыПечати).Выбрать();
	ПервыйДокумент = Истина;
	Пока ДанныеДляПечати.Следующий() Цикл
	
	//в теле пишем код для вывода

КонецЦикла;
	
	Возврат ДокументРезультат;
	
КонецФункции
/////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////

//выборка 2////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
Функция Наименование3(Регистратор, ПараметрыПечати)
	
	Запрос = Новый Запрос;
	Запрос.УстановитьПараметр("Сотрудник", Регистратор.Сотрудник);
	
	
	Запрос.Текст =
	"ВЫБРАТЬ
	|	КадроваяИсторияСотрудниковСрезПервых.Регистратор.ТрудовойДоговорНомер КАК РегистраторТрудовойДоговорНомер,
	|	КадроваяИсторияСотрудниковСрезПервых.Регистратор.ТрудовойДоговорДата КАК РегистраторТрудовойДоговорДата
	|ИЗ
	|	РегистрСведений.КадроваяИсторияСотрудников.СрезПервых КАК КадроваяИсторияСотрудниковСрезПервых
	|ГДЕ
	|	КадроваяИсторияСотрудниковСрезПервых.Сотрудник = &Сотрудник";
	
	Возврат Запрос.Выполнить();	
		
КонецФункции

ДанныеТД = ДанныеТрудовогоДоговора(ДанныеДляПечати.Ссылка, ПараметрыПечати).Выбрать();
		Пока ДанныеТД.Следующий() Цикл
			 ОбластьМакета.Параметры.ТрудовойДоговорДата = Формат(ДанныеТД.РегистраторТрудовойДоговорДата, "ДЛФ=DD");;
			 ОбластьМакета.Параметры.ТрудовойДоговорНомер = ДанныеТД.РегистраторТрудовойДоговорНомер; 
		КонецЦикла;
		
		ТабНомер = ПолучитьТабельныйНомер(ДанныеДляПечати.Ссылка, ПараметрыПечати).Выбрать();
		Пока  ТабНомер.Следующий() Цикл
			  ОбластьМакета.Параметры.ТабельныйНомер = ТабНомер.Код;
		КонецЦикла;
TurboConf - расширение Конфигуратора 1С

Похожие публикации

ПолучитьСтандартныеНастройки (БСП)

ВызватьСтандартноеИсключение (БСП)

ПриФормированииМанифестаКонфигурации (БСП)

ПараметрыФормированияДокументаHTMLНаОснованииПисьма (БСП)

ПоискКомпонентыНаПорталеПриФормированииРезультата (БСП)

Модератору