Сопоставления объектов проводок в базе-приемнике БП3 по COM-соединению

Функция СчетБазы(База,КодСчета,Предопределенный = Истина)
    Если Предопределенный Тогда
        Результат = База.ПланыСчетов.Хозрасчетный[КодСчета];
    Иначе
        Результат = База.ПланыСчетов.Хозрасчетный.НайтиПоКоду(КодСчета);
    КонецЕсли;
    
    Возврат Результат;
КонецФункции

Функция СубконтоБазы(База,ИмяСубконто,Предопределено = Истина,ИмяПВХСубконто = "ВидыСубконтоХозрасчетные")
    Если Предопределено = Истина Тогда
        Результат = База.ПланыВидовХарактеристик[ИмяПВХСубконто][ИмяСубконто];            
    Иначе
        Результат = База.ПланыВидовХарактеристик[ИмяПВХСубконто].НайтиПоНаименованию(ИмяСубконто);
    КонецЕсли;
    Возврат Результат;    
КонецФункции

Процедура УстановитьСубконтоБазы(База,Счет, Субконто, ИмяСубконто, ЗначениеСубконто)
    База.БухгалтерскийУчет.УстановитьСубконто(Счет, Субконто, ИмяСубконто, ЗначениеСубконто);
КонецПроцедуры
TurboConf - расширение Конфигуратора 1С

Похожие публикации

ВнешнееСоединениеСБазой (БСП)

СоединенияСИнформационнойБазой (БСП)

Обработка проводок по дереву

СвойстваСоединений (БСП)

Модератору