CSV в массив из структур

Перевести строку с заголовками (CSV) в массив из структур

Функция ПреобразоватьCSVвМассив(CSV)
	
	Разделитель        = Символы.Таб;
	ЗаголовкиCSV       = СокрЛП(СтрПолучитьСтроку(CSV,1));
	МассивЗаголовков   = СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивПодстрок(ЗаголовкиCSV, Разделитель, Ложь, );
	
	DATA = Новый Массив;
	Для НомерСтроки=2 По СтрЧислоСтрок(CSV) Цикл  
		Строка         = СтрПолучитьСтроку(CSV, НомерСтроки);
		МассивПодстрок = СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивПодстрок(Строка, Разделитель, Ложь, );
		Структура      = Новый Структура(СтрЗаменить(ЗаголовкиCSV,  Разделитель, ","));
		Инд            = 0;
		Для Каждого КлючЗначение Из Структура Цикл
			Структура[КлючЗначение.Ключ] = МассивПодстрок[Инд];
			Инд = Инд+1;
		КонецЦикла;
		DATA.Добавить(Структура);
	КонецЦикла;
		
	Возврат DATA;
		
КонецФункции
{5} Переменной МассивЗаголовков присвоено значение, но оно нигде не используется
FastCode - сервис для программистов 1С

Похожие публикации

Разложить массив по типам объектов

Преобразовать массив структур в ТаблицуЗначений

ТаблицаЗначенийВМассив (БСП)

ПреобразоватьТаблицуКонтактовВМассив (БСП)

ТаблицуКонтактовВМассив (БСП)

Модератору