Итоги в подвале таблицы с учетом отбора

Дамир 43 1 3

Штатные итоги в таблицах выводятся без учета установленных отборов

&НаКлиенте
Процедура ОбновитьИтоги(Команда)

    ДанныеТаб = Отчет.ТаблицаФормы1;
	Сумма1 = 0;
	Если Элементы.ТаблицаФормы1.ВыделенныеСтроки.Количество() > 1 тогда
		Для каждого с из Элементы.ТаблицаФормы1.ВыделенныеСтроки цикл
			стр = ДанныеТаб.НайтиПоИдентификатору(с);
			Сумма1 = Сумма1 + стр.СуммаЗатрат;
		КонецЦикла;
	Иначе
		Для каждого стр из ДанныеТаб цикл
			Если Элементы.ТаблицаФормы1.ПроверитьСтроку(стр.ПолучитьИдентификатор()) тогда
				 Сумма1 = Сумма1 + стр.СуммаЗатрат;
			КонецЕсли;
		КонецЦикла;
	КонецЕсли;
	Элементы.ТаблицаФормы1.ПодчиненныеЭлементы.ТаблицаФормы1СуммаЗатрат.ТекстПодвала = Формат(Сумма1,"ЧДЦ=2");
КонецПроцедуры
TurboConf - расширение Конфигуратора 1С

Комментарии

Дамир
#1, 09 ноября 2020 23:44

Для динамических список пробуем событие ПриПолученииДанныхНаСервере
Для табличных частей ПриАктивизацииСтроки


Похожие публикации

Последняя строка таблицы на одной странице вместе с подвалом

Отбор по таблице значений

Создать временную таблицу, с данными учета времени и состояний сотрудников

ПроверкиВеденияУчета (БСП)

СтрокаТаблицыРазрешений (БСП)

Модератору