УТ 11.4. Выбрать все документы, по определенному виду номенклатуры

buketoff 81 2 8

Список типов документов можно наполнить нужными. ВидНоменклатуры - реквизит на форме обработке или указывать программно

&НаСервере
Процедура ВыбратьДокументыНаСервере()
	
	ТЗДокументы.Очистить();
	
	СписокИменДокументов = СформироватьСписокСТипамиДокументов();
	
	ТекстЗапроса = "";
	
	Для каждого Вид Из СписокИменДокументов Цикл
		
		Если ТекстЗапроса<>"" Тогда
			ТекстЗапроса=ТекстЗапроса+"
			|ОБЪЕДИНИТЬ ВСЕ ";
		КонецЕсли;
			                           
		Шаблон =
		"ВЫБРАТЬ
		|  ТЧ.Ссылка КАК Ссылка,
		|  ТЧ.Номенклатура КАК Номенклатура
		|ИЗ
		|  Документ.ПриобретениеТоваровУслуг.Товары КАК ТЧ
		|ГДЕ ТЧ.Ссылка.Проведен И ТЧ.Номенклатура.ВидНоменклатуры = &ВидНоменклатуры";
		
		ТекстЗапроса = ТекстЗапроса+СтрЗаменить(Шаблон, "ПриобретениеТоваровУслуг", Вид);
		
	КонецЦикла; 	
	
	Запрос = Новый Запрос(ТекстЗапроса);
	Запрос.УстановитьПараметр("ВидНоменклатуры", ВидНоменклатуры);	
	Выборка = Запрос.Выполнить().Выбрать();
	Пока Выборка.Следующий() Цикл
		НоваСтрокаТЗ = ТЗДокументы.Добавить();
		НоваСтрокаТЗ.Документ = Выборка.Ссылка;
	КонецЦикла;
	
КонецПроцедуры

Функция СформироватьСписокСТипамиДокументов()
	
	СписокТиповДокументов = Новый Массив;
	
	СписокТиповДокументов.Добавить(Метаданные.Документы.ПриобретениеТоваровУслуг.Имя);
	СписокТиповДокументов.Добавить(Метаданные.Документы.ВозвратТоваровОтКлиента.Имя);
	СписокТиповДокументов.Добавить(Метаданные.Документы.ВозвратТоваровПоставщику.Имя);
	СписокТиповДокументов.Добавить(Метаданные.Документы.ПеремещениеТоваров.Имя);
	СписокТиповДокументов.Добавить(Метаданные.Документы.СборкаТоваров.Имя);
	СписокТиповДокументов.Добавить(Метаданные.Документы.ПрочееОприходованиеТоваров.Имя);
	
	Возврат СписокТиповДокументов;
	
КонецФункции 
FastCode - сервис для программистов 1С

Похожие публикации

Ограничение, одним видом документов, запроса из регистра

ВыбратьПутьККаталогуДанныхПользователя (БСП)

Выгрузка Запроса в XML документ, в виде дерева(В Виде иерархии)

ПриОпределенииВидовПодключаемыхКоманд (БСП)

Модератору