Актуальные символы препроцессора

SDV 91 4 10

Возвращает массив символов препроцессора актуальных при вызове. Функция может быть полезна в процессе изучения/освоения особенностей клиент-серверного взаимодействия. <Символ препроцессора> = {НаКлиенте | НаСервере | ТолстыйКлиентОбычноеПриложение | ТолстыйКлиентУправляемоеПриложение | Клиент | Сервер | ВнешнееСоединение }

&НаКлиентеНаСервере
Функция АктуальныеСимволыПрепроцессора() Экспорт
    
    Результат = новый Массив;
    
    #Если НаКлиенте Тогда
        Результат.Добавить("НаКлиенте");
    #КонецЕсли
    
    #Если НаСервере Тогда
        Результат.Добавить("НаСервере");
    #КонецЕсли
    
    #Если Клиент Тогда
        Результат.Добавить("Клиент");
    #КонецЕсли
    
    #Если Сервер Тогда
        Результат.Добавить("Сервер");
    #КонецЕсли
    
    #Если МобильноеПриложениеКлиент Тогда
        Результат.Добавить("МобильноеПриложениеКлиент");
    #КонецЕсли
    
    #Если МобильноеПриложениеСервер Тогда
        Результат.Добавить("МобильноеПриложениеСервер");
    #КонецЕсли
    
    #Если МобильныйКлиент Тогда
        Результат.Добавить("МобильныйКлиент");
    #КонецЕсли
    
    #Если ТолстыйКлиентОбычноеПриложение Тогда
        Результат.Добавить("ТолстыйКлиентОбычноеПриложение");
    #КонецЕсли
        
    #Если ТолстыйКлиентУправляемоеПриложение Тогда
        Результат.Добавить("ТолстыйКлиентУправляемоеПриложение");
    #КонецЕсли
    
    #Если ВнешнееСоединение Тогда
        Результат.Добавить("ВнешнееСоединение");
    #КонецЕсли
    
    #Если ТонкийКлиент  Тогда
        Результат.Добавить("ТонкийКлиент");
    #КонецЕсли
    
    #Если ВебКлиент  Тогда
        Результат.Добавить("ВебКлиент");
    #КонецЕсли
    
    Возврат Результат;

КонецФункции
FastCode - сервис для программистов 1С

Похожие публикации

ЗагрузитьАктуальныйКурс (БСП)

КурсыАктуальны (БСП)

АктуальныеВерсииВнешнихКомпонент (БСП)

ЗаменитьНедопустимыеСимволыXML (БСП)

ЭтоВебКлиент (БСП)

Модератору