"Использовать в качестве значения поле" программно

SeiOkami 247 4 3 6

В тех случаях, когда на таблице формы с отборами СКД необходимо по умолчанию в новых элементах включать галочку "Использовать в качестве значения поле"

&НаКлиенте
Процедура УсловияОтбораПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
	
	Если НЕ НоваяСтрока ИЛИ Копирование Тогда
		Возврат;
	КонецЕсли;
	
	ТекущаяСтрока = Элемент.ТекущаяСтрока;
	Если ТекущаяСтрока = Неопределено Тогда
		Возврат;
	КонецЕсли;
	
	ЭлементОтбора = КомпоновщикНастроек.Настройки.Отбор.ПолучитьОбъектПоИдентификатору(ТекущаяСтрока);
	Если ТипЗнч(ЭлементОтбора) <> Тип("ЭлементОтбораКомпоновкиДанных") Тогда
		Возврат;
	КонецЕсли;
	
	ЭлементОтбора.ЛевоеЗначение  = Новый ПолеКомпоновкиДанных("");
	ЭлементОтбора.ПравоеЗначение = Новый ПолеКомпоновкиДанных("");
	
КонецПроцедуры

Источник

TurboConf - расширение Конфигуратора 1С

Похожие публикации

ПоляАдреса (БСП)

Значение полей в расшифровке СКД

ПустыеЗначенияОпорныхПолей (БСП)

СтруктураЗначенийПолей (БСП)

СоответствиеРусскихИменПолейНастроекАнглийским (БСП)

Модератору