"Использовать в качестве значения поле" программно

SeiOkami 365 5 6 8

В тех случаях, когда на таблице формы с отборами СКД необходимо по умолчанию в новых элементах включать галочку "Использовать в качестве значения поле"

&НаКлиенте
Процедура УсловияОтбораПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
	
	Если НЕ НоваяСтрока ИЛИ Копирование Тогда
		Возврат;
	КонецЕсли;
	
	ТекущаяСтрока = Элемент.ТекущаяСтрока;
	Если ТекущаяСтрока = Неопределено Тогда
		Возврат;
	КонецЕсли;
	
	ЭлементОтбора = КомпоновщикНастроек.Настройки.Отбор.ПолучитьОбъектПоИдентификатору(ТекущаяСтрока);
	Если ТипЗнч(ЭлементОтбора) <> Тип("ЭлементОтбораКомпоновкиДанных") Тогда
		Возврат;
	КонецЕсли;
	
	ЭлементОтбора.ЛевоеЗначение  = Новый ПолеКомпоновкиДанных("");
	ЭлементОтбора.ПравоеЗначение = Новый ПолеКомпоновкиДанных("");
	
КонецПроцедуры

Источник

0

Рекомендации

См. также

ПоляАдреса (БСП)

Значение полей в расшифровке СКД

ПустыеЗначенияОпорныхПолей (БСП)

СтруктураЗначенийПолей (БСП)

СоответствиеРусскихИменПолейНастроекАнглийским (БСП)

ЗначениеФлажкаИспользоватьПоиск (БСП)

Передача таблицы значений в запрос

Возвращает сумму значений в поле [ИмяПоля] всех элементов коллекции

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз

Комментарии

Модератору