Опциональное выполнение метода в фоновом задании (БСП)

builin 89 1 3 3

Опциональное выполнение метода в фоне средствами БСП

Блог Жёлтая тетрадь 📒 http://t.me/yellow_pad

Процедура ВыполнитьВыгрузку(ВидВыгрузки, МестоВызова, ИсточникСсылка, ВФоне = Ложь, Отказ = Ложь) Экспорт
	
	Если НЕ ЗначениеЗаполнено(ИсточникСсылка) Тогда
		Возврат;
	КонецЕсли;
	
	Если ВФоне Тогда
		
		ДлительныеОперации.ВыполнитьПроцедуру(, "БизнесПроцессыСлужебный.ПолучитьВыборкуИВыгрузить", ВидВыгрузки, МестоВызова, ИсточникСсылка);
		
	Иначе
		
		БизнесПроцессыСлужебный.ПолучитьВыборкуИВыгрузить(ВидВыгрузки, МестоВызова, ИсточникСсылка);
		
	КонецЕсли; 
	
КонецПроцедуры
Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз

Похожие публикации

СостояниеЗадания (БСП)

ИмяМетодаФоновогоРезервногоКопирования (БСП)

ОтменитьВыполнениеЗадания (БСП)

ВыполнитьСейчасВФонеЗавершение (БСП)

ОтработатьПрямойВызов (БСП)

Модератору