Разные параметры ориентации для разных страниц печатной формы в БСП

builin 40 2 1

Блог Жёлтая тетрадь 📒 http://t.me/yellow_pad Передача нескольких табличных документов в подсистему печати для вывода пакета документов с индивидуальными параметрами печати для каждой страницы печатной формы.

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
	
	СтруктураТипов = ОбщегоНазначенияУТ.СоответствиеМассивовПоТипамОбъектов(МассивОбъектов);
	
	ПечатнаяФорма = УправлениеПечатью.СведенияОПечатнойФорме(КоллекцияПечатныхФорм, "ext_ТОРГ2_АктОРасхожденияхПослеПриемки");
	Если ПечатнаяФорма <> Неопределено Тогда
		МассивТабличныхДокументов = СформироватьПечатнуюФормуТорг2(СтруктураТипов, ОбъектыПечати, ПараметрыВывода);
        //в массив возвращаем столько частей печатной формы, сколько нужно, задав для каждой ориентацию и масштаб
		Для К = 1 По МассивТабличныхДокументов.Количество() Цикл
			НоваяСтрока = КоллекцияПечатныхФорм.Добавить();
			ЗаполнитьЗначенияСвойств(НоваяСтрока, ПечатнаяФорма);
			НоваяСтрока.ТабличныйДокумент = МассивТабличныхДокументов[К-1];
			НоваяСтрока.ИмяМакета = НоваяСтрока.ИмяМакета + К;
			НоваяСтрока.ИмяВРЕГ = НоваяСтрока.ИмяВРЕГ + К;
			НоваяСтрока.СинонимМакета = СтрШаблон(НСтр("ru = 'ТОРГ-2 [%1 из %2]'"), К, МассивТабличныхДокументов.Количество());
		КонецЦикла; 
		КоллекцияПечатныхФорм.Удалить(ПечатнаяФорма);
	КонецЕсли;
	
	ФормированиеПечатныхФорм.ЗаполнитьПараметрыОтправки(ПараметрыВывода.ПараметрыОтправки, МассивОбъектов, КоллекцияПечатныхФорм);

КонецПроцедуры
Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз

Похожие публикации

ЗаполнитьПараметры (БСП)

ЗаполнитьПараметрыНижнегоКолонтитула (БСП)

ЗаполнитьПараметрыВерхнегоКолонтитула (БСП)

НоваяКоллекцияПечатныхФорм (БСП)

ПередОтправкойПоПочте (БСП)

Модератору