1с82. Прикрепление файла к документу. Обычное приложение

buketoff 93 1 1 9

Прикрепление файла к документу. Обычное приложение.

Процедура ПрикрепитьФайлНажатие(Элемент)
	
	Режим = РежимДиалогаВыбораФайла.Открытие;
	
	ДиалогОткрытия = Новый ДиалогВыбораФайла(Режим);
	ДиалогОткрытия.ПолноеИмяФайла = "";
	Фильтр = "Текст, *.pdf|*.pdf";
	ДиалогОткрытия.Фильтр = Фильтр;
	ДиалогОткрытия.МножественныйВыбор = Истина;
	ДиалогОткрытия.Заголовок = "Выберите файлы";
	Если ДиалогОткрытия.Выбрать() Тогда
		МассивВыбранныхФайлов = ДиалогОткрытия.ВыбранныеФайлы;
		Для Каждого ИмяВыбранногоФайла Из МассивВыбранныхФайлов Цикл
			
			
			ВыбранныйФайл = Новый Файл(ИмяВыбранногоФайла);
			
			Если ЭтотОбъект.Ссылка = Неопределено Тогда
				Возврат;
			Иначе
				ДокументСсылка    = ЭтотОбъект.Ссылка;	
				УИДДокумента       = ДокументСсылка.УникальныйИдентификатор();		
				КаталогНаДиске = Новый Файл("\\SERVER\file_storage\" + Строка(УИДДокумента));
				Если КаталогНаДиске.Существует() Тогда
					ПутьКФайлуИсточнику = "";
					КопироватьФайл(ВыбранныйФайл.ПолноеИмя, КаталогНаДиске.ПолноеИмя + "\" + ВыбранныйФайл.Имя);
				Иначе
					СоздатьКаталог("\\SERVER\file_storage\" + Строка(УИДДокумента));
					КаталогНаДиске = Новый Файл("\\SERVER\file_storage\" + Строка(УИДДокумента));
					Если КаталогНаДиске.Существует() Тогда
						КопироватьФайл(ВыбранныйФайл.ПолноеИмя, КаталогНаДиске.ПолноеИмя + "\" + ВыбранныйФайл.Имя);
					КонецЕсли;
				КонецЕсли;
			КонецЕсли;
			
		КонецЦикла;
	Иначе
		Предупреждение("Нет выбранных файлов!");
	КонецЕсли;
	
КонецПроцедуры
0

Рекомендации

См. также

Правило обмена прикрепленных файлов

КОбъектуМожноПрисоединятьФайлы (БСП)

СформироватьПечатныеФормыДляБыстройПечатиОбычноеПриложение (БСП)

ПолучитьДокументHTMLИзОбычногоТекста (БСП)

Строковые функции. Альтернатива для СтрРазделить, СтрНайти и т.д.

Раскраска строки табличной части документа (обычные формы) по условию

Работа с ЭЦП, прикрепленная подпись

ПоказатьДокументMSWord (БСП)

TurboConf - расширение Конфигуратора 1С

Комментарии

Модератору