Таблица Значений Без Null

SeiOkami 365 5 6 8

Функция возвращает копию переданной таблицы значений, но исключая из всех колонок тип Null Бывает полезна для обработки выгрузки запроса, в котором у каждой колонки есть тип Null

Источник: https://t.me/JuniorOneS

// Функция возвращает копию переданной таблицы значений, но исключая из всех колонок тип Null
// Бывает полезна для обработки выгрузки запроса, в котором у каждой колонки есть тип Null
//
// Параметры:
//  ТаблицаЗначений  - ТаблицаЗначений - Таблица значений источник
//
// Возвращаемое значение:
//   ТаблицаЗначений   - Таблица без Null
//
Функция ТаблицаЗначенийБезNull(ТаблицаЗначений) Экспорт
	
	НоваяТаблица = Новый ТаблицаЗначений;
	Для Каждого ТекущаяКолонка Из ТаблицаЗначений.Колонки Цикл
		ОписаниеТипа = Новый ОписаниеТипов(ТекущаяКолонка.ТипЗначения, ,"NULL");
        НоваяТаблица.Колонки.Добавить(ТекущаяКолонка.Имя, ОписаниеТипа,
		ТекущаяКолонка.Заголовок, ТекущаяКолонка.Ширина);
    КонецЦикла;
	
	Для Каждого ТекущаяСтрока Из ТаблицаЗначений Цикл
        ЗаполнитьЗначенияСвойств(НоваяТаблица.Добавить(), ТекущаяСтрока);
    КонецЦикла;
    
    Возврат НоваяТаблица;

КонецФункции
2

Рекомендации

См. также

Заполнение пропусков в таблице цветов

ТаблицаЗначенийВТаблицуХТМЛ

Сохранение таблицы значений в XML

Отбор по таблице значений

Дополнить таблицу значений - приемника данными из таблицы значений - источника

ЗаполнитьТаблицуЗначений (БСП)

Типизация таблицы значений

Поиск в таблице значений неуникальных значений

ТаблицаЗначенийВМассив (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз

Комментарии

Eremkin Igor
#1, 16 апреля 2021 18:14

Для тех, кому лень писать ЕСТЬNULL в запросе


SeiOkami
#2, ред. 16 апреля 2021 20:06

(1) Eremkin Igor, ЕстьNull() никак не изменит тип колонки. И если ты будешь кодом работать с таблицей, то в ней может быть тип Null


Модератору