Свернуть табличную часть

SeiOkami 247 4 3 6

Сворачивает табличную часть по всем колонкам. Числовые колонки при этом суммируются

Источник: https://t.me/JuniorOneS

// Сворачивает табличную часть по всем колонкам. 
// Числовые колонки при этом суммируются
//
// Параметры:
//  Объект  - Произвольный - Объект, который имеет Метаданные и Табличную часть
//  ИмяТабличнойЧасти  - Строка - Имя табличной части
//
Процедура СвернутьТабличнуюЧасть(Объект, ИмяТабличнойЧасти) Экспорт
	
	ИзмеренияТаблицы = Новый Массив;
	РесурсыТаблицы   = Новый Массив;
	
	КолонкиТабличнойЧасти = Объект.Метаданные().ТабличныеЧасти[ИмяТабличнойЧасти].Реквизиты;
	Для Каждого МетаданныеКолонки Из КолонкиТабличнойЧасти Цикл
		Если МетаданныеКолонки.Тип.СодержитТип(Тип("Число")) Тогда
			РесурсыТаблицы.Добавить(МетаданныеКолонки.Имя);
		Иначе
			ИзмеренияТаблицы.Добавить(МетаданныеКолонки.Имя);
		КонецЕсли;
	КонецЦикла;
	
	Объект[ИмяТабличнойЧасти].Свернуть(
		СтрСоединить(ИзмеренияТаблицы, ","), 
		СтрСоединить(РесурсыТаблицы, ",")
	);
	
КонецПроцедуры
FastCode - сервис для программистов 1С

Похожие публикации

МетаданныеТабличнойЧасти (БСП)

ТабличныеЧастиОбъекта (БСП)

Расчет суммы в строке табличной части

Как загрузить в табличную часть одного документа табличную часть другого документа?

МетаданныеРеквизитаТабличнойЧасти (БСП)

Модератору