Свернуть табличную часть

SeiOkami 434 5 9 9

Сворачивает табличную часть по всем колонкам. Числовые колонки при этом суммируются

Источник: https://t.me/JuniorOneS

// Сворачивает табличную часть по всем колонкам. 
// Числовые колонки при этом суммируются
//
// Параметры:
//  ТабличнаяЧасть - ТабличнаяЧасть
//
Процедура СвернутьТабличнуюЧасть(ТабличнаяЧасть) Экспорт
	
	Ресурсы = Новый Массив; // Массив из Строка
	Измерения = Новый Массив; // Массив из Строка
	
	МетаданныеТабличнойЧасти = Метаданные.НайтиПоТипу(ТипЗнч(ТабличнаяЧасть)); // ОбъектМетаданныхТабличнаяЧасть
	Для Каждого МетаданныеКолонки Из МетаданныеТабличнойЧасти.Реквизиты Цикл
		ИмяКолонки = МетаданныеКолонки.Имя;
		Если МетаданныеКолонки.Тип.СодержитТип(Тип("Число")) Тогда
			Ресурсы.Добавить(ИмяКолонки);
		Иначе
			Измерения.Добавить(ИмяКолонки);
		КонецЕсли;
	КонецЦикла;
	
	ИменаИзмерений = СтрСоединить(Измерения, ",");
	ИменаРесурсов = СтрСоединить(Ресурсы, ",");
	
	ТабличнаяЧасть.Свернуть(ИменаИзмерений, ИменаРесурсов);
	
КонецПроцедуры
0

См. также

Программно свернуть все уровни группировок табличного документа

МетаданныеТабличнойЧасти (БСП)

ТабличныеЧастиОбъекта (БСП)

Расчет суммы в строке табличной части

Как загрузить в табличную часть одного документа табличную часть другого документа?

МетаданныеРеквизитаТабличнойЧасти (БСП)

Пересчет сумм в табличной части документа

пересчет реквизита табличной части обычной формы

ЗаполнитьТабличнуюЧастьОбъектаНачальнымиДанными (БСП)

Модератору