Добавить или обновить колонку

SeiOkami 247 4 3 6

Добавляет колонку в таблицу значений Если колонка уже есть, то обновляет свойства Заголовок и Ширина Возвращает добавленную или найденную колонку

Источник: https://t.me/JuniorOneS

// Добавляет колонку в таблицу значений
// Если колонка уже есть, то обновляет свойства Заголовок и Ширина
//
// Параметры:
//  ТаблицаЗначений  - ТаблицаЗначений - Таблица значений, в которую нужно добавить колонку
//  Имя              - Строка - Имя колонки
//  Тип              - ОписаниеТипов, Неопределено - Объект, описывающий допустимые типы значений для колонки. 
//                 Если параметр не указан, в колонке можно будет хранить значение любого типа.
//  Заголовок        - Строка, Неопределено - Заголовок колонки таблицы значений.
//                 Используется при визуальном отображении таблицы значений.
//  Ширина           - Строка, Неопределено - Ширина колонки в символах.
//                 Используется при визуальном отображении таблицы значений.
//
// Возвращаемое значение:
//   КолонкаТаблицыЗначений - добавленная (или найденная) колонка 
//
Функция ДобавитьКолонкуБезопасно(ТаблицаЗначений, Имя, 
	Тип = Неопределено, Заголовок = Неопределено, Ширина = Неопределено) Экспорт
	
	Колонка	= ТаблицаЗначений.Колонки.Найти(Имя);
	
	Если Колонка = Неопределено Тогда
		Колонка	= ТаблицаЗначений.Колонки.Добавить(Имя, Тип);
	КонецЕсли;
	
	Если Заголовок <> Неопределено Тогда
		Колонка.Заголовок	= Заголовок;
	КонецЕсли;
	
	Если Ширина <> Неопределено Тогда
		Колонка.Ширина	= Ширина;
	КонецЕсли;
	
	Возврат Колонка;
	
КонецФункции
FastCode - сервис для программистов 1С

Похожие публикации

ДобавитьИтераторТаблице

Добавить (БСП)

Конструктор массива (Массив = Массив(Значение1, ... , Значение20))

КолонкиДляЗагрузкиДанных (БСП)

КолонкиИмеютГруппировку (БСП)

Модератору