Как загрузить в табличную часть одного документа табличную часть другого документа?

Добрый день, помогите пожалуйста: У меня есть таблица ОказаниеУслуги с табличной частью Тираж(Номенклатура, НаборСвойств,Количество, Цена, Сумма) и документ Доставка с табличной частью Тираж (Номенклатура, НаборСвойств,Количество, Цена, Сумма - тоже самое то есть), хочу в ТЧ на форме документа Доставка передать ТЧ определенного документа ОказаниеУслуги, номер которого указывается на форме Доставка

Типы данных в ТЧ первого и второго документа - СправочникСсылка.Номенклатура, СправочникСсылка.ВариантыНоменклатуры, Число, Число,Число

Вот что я пыталась использовать:

Процедура  ЗаполнитьТабличнуюЧасть()
    Объект.Тираж.Очистить();    
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    ОказаниеУслуги.Тираж.(
        |        Ссылка КАК Ссылка,
        |        НомерСтроки КАК НомерСтроки,
        |        Номенклатура КАК Номенклатура,
        |        НаборСвойств КАК НаборСвойств,
        |        Количество КАК Количество,
        |        Цена КАК Цена,
        |        Сумма КАК Сумма
        |    ) КАК Тираж
        |ИЗ
        |    Документ.ОказаниеУслуги КАК ОказаниеУслуги
        |ГДЕ
        |    ОказаниеУслуги.Номер = &НомерЗаказа";
    Запрос.УстановитьПараметр("НомерЗаказа",Объект.Номер);
    Результат = Запрос.Выполнить().Выбрать();

    Пока Результат.Следующий() Цикл
        НоваяСтрока = Объект.Тираж.Добавить();
        
        НоваяСтрока.Номенклатура = Результат;
    КонецЦикла;
 КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
     ЗаполнитьТабличнуюЧасть();
КонецПроцедуры

В Тираж документа Доставки вставляется одна строка с пустыми значениями (когда записей в первой ТЧ несколько)
Я находила решения в том числе здесь, но это были случаи передачи реквизитов документов а не реквизитов табличных частей... Немного затрудняюсь как быть

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз

Ответы

markers
#1, ред. 16 апреля 2021 04:00

делайте запрос к документу для отбора и внутренним соединением цепляйте сразу его табличную


safym
#2, 16 апреля 2021 04:10

(1) markers, простите, наверное забыла упомянуть
у меня только в одной табличной части есть записи, вторая пустая, получается у меня нет признака для соединения...?


markers
#3, ред. 16 апреля 2021 04:44

(2) safym, В общем запрос должен быть примерно такой:

ВЫБРАТЬ
	ЧекККМТовары.Номенклатура КАК Номенклатура,
	ЧекККМТовары.Количество КАК Количество,
	ЧекККМТовары.Цена КАК Цена,
	ЧекККМТовары.Сумма КАК Сумма
ИЗ
	Документ.ЧекККМ КАК ЧекККМ
		ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.ЧекККМ.Товары КАК ЧекККМТовары
		ПО (ЧекККМ.Ссылка = ЧекККМТовары.Ссылка)
ГДЕ
	ЧекККМ.Номер = &Номер

Мне правда не нравится ваш отбор по номеру, лучше отбирать по ссылке, но то не суть.


Похожие публикации

Заполнить счета учета

Пересчет сумм в табличной части документа

Раскраска строки табличной части документа (обычные формы) по условию

ПолучитьУчастниковПоТаблице (БСП)

Заполнить реквизит "СуммаДокумента "на форме документа

Модератору