Вызов процедур или функций модуля объекта из модуля формы

Дамир 43 1 3

Когда из модуля формы нужно вызвать экспортную процедуру или функцию из его же модуля объекта

&НаСервере
Процедура ПодключитьсяНаСервере()
	
	ТекОбъект = РеквизитФормыВЗначение("Объект");//Для отчета "Отчет"
	ТекОбъект.ЭкспортныйВызовИзМодуляОбъекта();
	
	//если содержимое Объект поменялось и нужно обновить его на форме, то делаем:
	ЗначениеВРеквизитФормы(ТекОбъект, "Объект");
	
КонецПроцедуры
TurboConf - расширение Конфигуратора 1С

Комментарии

VolAll
#1, ред. 01 июня 2021 17:17

&НаСервере
Перем ОбработкаОбъект;
&НаСервере
Функция ОбработкаОбъект()
  Если ОбработкаОбъект = Неопределено Тогда    
    СтруктураОбработки = ПолучитьИзВременногоХранилища(Объект.ОбщийКонтекстКлиентСервер.АдресОбработкаОбъект);    
    Если СтруктураОбработки <> Неопределено Тогда
      ОбработкаОбъект = СтруктураОбработки.ОбработкаОбъект;
    КонецЕсли;    
    Если ОбработкаОбъект = Неопределено Тогда      
      ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
      Попытка
        ПоместитьВоВременноеХранилище(Новый Структура("ОбработкаОбъект", ОбработкаОбъект), Объект.ОбщийКонтекстКлиентСервер.АдресОбработкаОбъект);
      Исключение
      КонецПопытки;      
    Иначе
      ОбработкаОбъект.ОбщийКонтекстКлиентСервер = Объект.ОбщийКонтекстКлиентСервер;
    КонецЕсли;    
  КонецЕсли;    
  Возврат ОбработкаОбъект;  
КонецФункции


Похожие публикации

НоваяКоллекцияПечатныхФорм (БСП)

Упорядочивание (сортировка) массива

УстановкаПараметровСеанса (БСП)

ВыполнитьПроцедуруМодуляОбъектаОбработки (БСП)

ВыполнитьПроцедуруМодуляОбъектаОтчета (БСП)

Модератору