Показать вопрос

sr.epifanov 14 1

Диалог подтверждения действия пользователем

&НаКлиенте
Процедура КомандаСпроситьУПользователя(Команда)
	
	Оповещение = Новый ОписаниеОповещения("КомандаСпроситьУПользователяЗавершение", ЭтаФорма, Неопределено);
	ТекстВопроса = "Будет выполнено некое действие. Продолжить?";
	ПоказатьВопрос(Оповещение, ТекстВопроса, РежимДиалогаВопрос.ДаНет);
	
КонецПроцедуры

&НаКлиенте
Процедура КомандаСпроситьУПользователяЗавершение(Результат, ДополнительныеПараметры = Неопределено) Экспорт
	
	Если Результат = КодВозвратаДиалога.Нет Тогда
		Возврат;
	КонецЕсли;
	
        // Сделать что нужно
	
КонецПроцедуры
Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз

Комментарии

prog1c
#1, 26 мая 2021 04:31

Добавьте пожалуйста в создание оповещения структуру ДополнительныеПараметры , чтобы не дописывать каждый раз


Похожие публикации

ПоказатьВопросПользователю (БСП)

ПоказатьВопросУстановкиКомпонентыСканирования (БСП)

ПоказатьВопросЗаписиНовогоВладельца (БСП)

ПоказатьВопросОбУстановкеРасширенияРаботыСФайлами (БСП)

ПоказатьПодтверждениеЗакрытияПроизвольнойФормы (БСП)

Модератору